Bug 984 - Directory manipulations in 3.0.x loosing ACK packets
Directory manipulations in 3.0.x loosing ACK packets
Status: RESOLVED INVALID
Product: Samba 3.0
Classification: Unclassified
Component: File Services
3.0.1
All Linux
: P3 normal
: none
Assigned To: Gerald (Jerry) Carter
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-18 14:34 UTC by Charles
Modified: 2005-11-14 09:27 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Charles 2004-01-18 14:34:14 UTC
I have experienced this problem on RH AS 3.0 with kernel 2.4.21 and Samba 3.0.0
as well as Kernel 2.6.1 with Samba releases 3.0.1, 3.0.2pre1 and 3.0.2rc1. 
Kernel 2.6.1 and Samba 2.2.8 do NOT have this behaviour, and Solaris 9 with
Samba 3.0.1pre1 also does not seem to have this behaviour.

Hardware is a Dual processor Xeon, 2Ghz PC-DL motherboard.
Clients to have experienced this problem are Windows XP on gigabit, Windows 2K
on 100Mb and Windows XP on 802.11g.

Here is a tcpdump of the problem...vampire is the server, phantom is the client
16:09:40.274622 phantom..1931 > vampire..netbios-ssn: P 99039:99291(252) ack
11056688 win 63727 NBT Packet (DF)
16:09:40.314331 vampire..netbios-ssn > phantom..1931: . ack 99291 win 12864
(DF)16:09:44.425623 vampire..netbios-ssn > phantom..1931: P
11056688:11056810(122) ack 99291 win 12864 NBT Packet (DF)
*ACK RETRANS16:09:50.374161 phantom..1931 > vampire..netbios-ssn: P
122535:122615(80) ack 14799792 win 63859 NBT Packet (DF)
16:09:50.552663 phantom..1931 > vampire..netbios-ssn: . ack 14802479 win 64201 (DF)
16:09:52.238184 phantom..1931 > vampire..netbios-ssn: P 125122:125202(80) ack
14802479 win 64201 NBT Packet (DF)
16:09:52.238323 vampire..netbios-ssn > phantom..1931: P 14802479:14802583(104)
ack 125202 win 12864 NBT Packet (DF)
                                                                                
16:09:50.374161 phantom..1931 > vampire..netbios-ssn: P 122535:122615(80) ack
14799792 win 63859 NBT Packet (DF)
16:09:50.552663 phantom..1931 > vampire..netbios-ssn: . ack 14802479 win 64201 (DF)
* ACK RETRANS
16:09:52.238184 phantom..1931 > vampire..netbios-ssn: P 125122:125202(80) ack
14802479 win 64201 NBT Packet (DF)
16:09:52.238323 vampire..netbios-ssn > phantom..1931: P 14802479:14802583(104)
ack 125202 win 12864 NBT Packet (DF)

16:09:56.363392 phantom..1931 > vampire..netbios-ssn: P 150497:150749(252) ack
18535074 win 63265 NBT Packet (DF)
16:09:56.403210 vampire..netbios-ssn > phantom..1931: . ack 150749 win 12864 (DF)
*ACK RETRANS
16:10:00.513148 vampire..netbios-ssn > phantom..1931: P 18535074:18535196(122)
ack 150749 win 12864 NBT Packet (DF)
16:10:00.513684 phantom..1931 > vampire..netbios-ssn: P 150749:150833(84) ack
18535196 win 63143 NBT Packet (DF)

etc...
The bug reproducable by double clicking on a folder, or by clicking on an icon,
moving it a bit, then attempting to click on another icon.  You'll notice it
takes several seconds for the next icon to be highlighted.

This problem only occurs when doing directory manipulations and navigations.  If
the file on the Samba server is dragged to the desktop for copy, the copy
performance is normal.  In other words, it only appears t o be    happening on
netbios-ssn type packets.            

I would be happy to provide any further required tcpdumps or other information.

Thanks!
Comment 1 Gerald (Jerry) Carter 2004-03-16 12:03:48 UTC
Charles, please provide detailed server logs with 
timestamps that show a delay in smbd.  Thanks.
Comment 2 Gerald (Jerry) Carter 2004-04-22 20:11:39 UTC
no feedback.  Looks like a kernel issue anyways.  CLosing.
Comment 3 Gerald (Jerry) Carter 2005-11-14 09:27:19 UTC
database cleanup