Bug 9835 - userParameters attribute not synched to other DCs
userParameters attribute not synched to other DCs
Status: RESOLVED DUPLICATE of bug 8077
Product: Samba 4.0
Classification: Unclassified
Component: AD: LDB/DSDB/SAMDB
4.0.5
All All
: P5 normal
: ---
Assigned To: Andrew Bartlett
Samba QA Contact
:
Depends on: 8077
Blocks:
  Show dependency treegraph
 
Reported: 2013-04-30 07:06 UTC by Björn Jacke
Modified: 2013-06-27 09:01 UTC (History)
1 user (show)

See Also:


Attachments
ldbsearch binary from dc (12.84 KB, text/plain)
2013-04-30 09:44 UTC, Björn Baumbach
no flags Details
ldbsearch binary from dc2 (13.20 KB, text/plain)
2013-04-30 09:44 UTC, Björn Baumbach
no flags Details
ldbsearch from dc (1.77 KB, text/plain)
2013-04-30 09:45 UTC, Björn Baumbach
no flags Details
ldbsearch from dc2 (2.27 KB, text/plain)
2013-04-30 09:45 UTC, Björn Baumbach
no flags Details
drs showrepl dc (2.99 KB, text/plain)
2013-04-30 09:46 UTC, Björn Baumbach
no flags Details
drs showrepl dc2 (2.98 KB, text/plain)
2013-04-30 09:46 UTC, Björn Baumbach
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Björn Jacke 2013-04-30 07:06:46 UTC
when the terminal server profile path is being set this is saved in the userParameters attribute. Setting this however results in the attribute only being saved on the DC where the change was done. The attribute is not being synced to other DCs. Tested with two Samba 4.0.5 AD DCs and w2k8r2's remote admin tools
Comment 1 Stefan Metzmacher 2013-04-30 07:27:10 UTC
We need the output of
ldbsearch ...  replPropertyMetaData userParameters
with and without "--show-binary -d 1" from both DCs.

Also the samba-tool drs showrepl <dcX> output for both DCs.

You should also check that modifying any other attribute on the same object
gets replicated.
Comment 2 Björn Baumbach 2013-04-30 09:44:03 UTC
Created attachment 8834 [details]
ldbsearch binary from dc
Comment 3 Björn Baumbach 2013-04-30 09:44:40 UTC
Created attachment 8835 [details]
ldbsearch binary from dc2
Comment 4 Björn Baumbach 2013-04-30 09:45:17 UTC
Created attachment 8836 [details]
ldbsearch from dc
Comment 5 Björn Baumbach 2013-04-30 09:45:44 UTC
Created attachment 8837 [details]
ldbsearch from dc2
Comment 6 Björn Baumbach 2013-04-30 09:46:20 UTC
Created attachment 8838 [details]
drs showrepl dc
Comment 7 Björn Baumbach 2013-04-30 09:46:54 UTC
Created attachment 8839 [details]
drs showrepl dc2
Comment 8 Björn Baumbach 2013-04-30 09:48:47 UTC
(In reply to comment #1)
> We need the output of
> ldbsearch ...  replPropertyMetaData userParameters
> with and without "--show-binary -d 1" from both DCs.
> 
> Also the samba-tool drs showrepl <dcX> output for both DCs.

attached.

> You should also check that modifying any other attribute on the same object
> gets replicated.

I modified the "mail:" attribute. That is working as expected.

Björn
Comment 9 Björn Baumbach 2013-04-30 09:56:52 UTC
This issue might depend on bug 8077.
Comment 10 Matthieu Patou 2013-05-01 06:33:30 UTC
ihmo it's a dup of 8077.

We need to handle more correctly the userParameters attribute which is a complex structure (not a pure string).

There was a discussion with dochelp back in 2011.
Comment 11 Björn Jacke 2013-06-27 08:26:25 UTC
it might be related but this is not obviously a dup of the " userParameters needs to be stored as utf8" bug. But non-working replication of the teminal server attributes etc. is a blocker for 4.1 i think
Comment 12 Andrew Bartlett 2013-06-27 08:36:57 UTC
it's the same bug, just different views.

The issue is we need a two-way 'UCS2' to 'utf8' conversion (not following the rules about invalid sequences), rather than a proper character conversion to be applied to this attribute.

*** This bug has been marked as a duplicate of bug 8077 ***