Bug 9829 - server/client min/max protocol are inconsistent
server/client min/max protocol are inconsistent
Status: RESOLVED DUPLICATE of bug 9974
Product: Samba 4.0
Classification: Unclassified
Component: File services
4.0.5
All All
: P5 normal
: ---
Assigned To: Samba QA Contact
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-04-25 09:27 UTC by Björn Jacke
Modified: 2013-08-19 21:37 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Björn Jacke 2013-04-25 09:27:13 UTC
"testparn -vs|grep proto" gives:

        server max protocol = SMB3
        server min protocol = LANMAN1
        client max protocol = 
        client min protocol = 

- "client * protocol" should give out the same as "server * max protocol"

- the default of "min protocol" is not the default that is documented in the smb.conf man page - that says NT1.
Comment 1 Björn Baumbach 2013-04-25 09:33:16 UTC
As far as I know the default _is_ NT1, because our client tools don't take of these settings at all and use simply use NT1 :-)
Comment 2 Jeremy Allison 2013-08-19 21:37:16 UTC
This is fixed with the patchset for adding SMB2/3 support to smbclient in bug #9974.

Jeremy.

*** This bug has been marked as a duplicate of bug 9974 ***