Bug 9819 - Samba refuses with ACCESS_DENIED requests for DELETE_ON_CLOSE that W2K08 allows
Samba refuses with ACCESS_DENIED requests for DELETE_ON_CLOSE that W2K08 allows
Status: RESOLVED DUPLICATE of bug 9757
Product: Samba 4.0
Classification: Unclassified
Component: File services
unspecified
All All
: P5 normal
: ---
Assigned To: Samba QA Contact
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-04-20 22:45 UTC by Richard Sharpe
Modified: 2013-04-21 00:53 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Richard Sharpe 2013-04-20 22:45:17 UTC
If a client requests DELETE access and DELETE_ON_CLOSE in the create options and OPEN_IF or OVERWRITE_IF and the file does not exist (ie, it is to be created) and the parent directory where the creation is to occur does not give the requestor DELETE_CHILD, W2K08R2 still allows the open. 

Samba responds with ACCESS_DENIED.

The new smb2.delete_on_close tests the relevant cases.
Comment 1 Richard Sharpe 2013-04-21 00:53:10 UTC

*** This bug has been marked as a duplicate of bug 9757 ***