Bug 978 - Bug in strupper_m and strlower_m
Bug in strupper_m and strlower_m
Status: RESOLVED DUPLICATE of bug 922
Product: Samba 3.0
Classification: Unclassified
Component: Extended Characters
3.0.1
All AIX
: P3 normal
: none
Assigned To: Alexander Bokovoy
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-16 05:01 UTC by Heinrich Mislik
Modified: 2005-11-14 09:24 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Heinrich Mislik 2004-01-16 05:01:43 UTC
From file util_str.c in function strupper_m: 

 while (*s && !(((unsigned char)s[0]) & 0x7f)) {

The expression !(((unsigned char)s[0]) & 0x7f) is FALSE for all values of s[0]
except 0 and 0x80. The desired optimization never takes place. Should be
corrected to:

 while (*s && !(((unsigned char)s[0]) & 0x80)) {

Same for strlower_m.
Comment 1 Gerald (Jerry) Carter 2004-03-17 07:34:26 UTC

*** This bug has been marked as a duplicate of 922 ***
Comment 2 Gerald (Jerry) Carter 2005-11-14 09:24:12 UTC
database cleanup