Bug 9771 - rpcclient publish printer doesnt write attribute printShareName
Summary: rpcclient publish printer doesnt write attribute printShareName
Status: ASSIGNED
Alias: None
Product: Samba 4.1 and newer
Classification: Unclassified
Component: Printing (show other bugs)
Version: 4.12.6
Hardware: x64 All
: P5 normal (vote)
Target Milestone: ---
Assignee: Björn Jacke
QA Contact: Samba QA Contact
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-04-08 11:31 UTC by tRew
Modified: 2020-09-18 01:59 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description tRew 2013-04-08 11:31:02 UTC
I recently installed cups and samba to be able to replace a windows printserver and to my surprise the printers wont show up in the "Add Printer" wizard in windows 7. It turns out that the command "net -U xxx ads printer publish yyy" doesnt write the attribute "printShareName" on the printer object in Active Directory.

There are a few other attributes which windows print server printers have but samba print server printers dont. These does not seem to have any impact on the problem.

Did i do this wrong or is there some configuration option i missed? (i know this is not a support forum but i had to ask).
Comment 1 tRew 2013-04-08 11:32:14 UTC
Version according to smbd --version and winbindd --version:
3.6.9-151.el6

Its running on CentOS 6.3
Comment 2 Emil Kristensen 2020-09-07 15:06:31 UTC
I have the same problem. I have to edit the "printShareName" manually in "ADSI Edit (adsiedit.msc)" in Windows to make the printer show up in the "Add printer" dialogue.

I've tried to search the internet for a solution as this issue is quite old now, but I cannot find any solution online. This is the issue that best describe the problem I have.

I run CentOS Linux release 8.1.1911 (Core) with Samba 4.10.4

Anybody who have resolved this issue?
Comment 3 Björn Jacke 2020-09-07 15:12:51 UTC

*** This bug has been marked as a duplicate of bug 9578 ***
Comment 4 Björn Jacke 2020-09-08 07:33:05 UTC
doesn't make much sense to mark this as duplicate of 9578 because that bug is about a number of optional atttributes while this is about a mandatory attribute for printer publishing to work. I have a fix for this one here.
Comment 5 Emil Kristensen 2020-09-08 09:23:07 UTC
(In reply to Björn Jacke from comment #4)

True. I wanted to argue like you, but you realized it before I could write it. It sounds great that you have a fix for this.

If you need help testing the fix I'll be happy to try to help.
Comment 6 Samba QA Contact 2020-09-18 01:59:06 UTC
This bug was referenced in samba master:

787d7756b99f182cc91c4c4215b8a5657a6d25d7
380938b00fb9fdb5b100e77000a059199695f43a