Bug 9681 - Reverse DNS zone
Reverse DNS zone
Status: RESOLVED INVALID
Product: Samba 4.0
Classification: Unclassified
Component: DNS server
4.0.3
All All
: P5 normal
: ---
Assigned To: Kai Blin
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-26 04:08 UTC by Michael Mol
Modified: 2013-05-25 10:11 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Mol 2013-02-26 04:08:46 UTC
So I've created an AD domain with a samba4 domain, and I've joined a few machines to it. Samba4 is doing an OK job serving as a network DNS server[1], but it isn't providing a dynamically-updated reverse DNS zone. (If it's capable of this, I haven't yet found the documentation for it.)

It would be a very god thing for Samba4 to provide; for me, that's a major selling point in deploying it on my network.

domainlist for the sole DC reads:

  2 zone(s) found

  pszZoneName                 : firefly.michael.mol.name
  Flags                       : DNS_RPC_ZONE_DSINTEGRATED DNS_RPC_ZONE_UPDATE_SECURE 
  ZoneType                    : DNS_ZONE_TYPE_PRIMARY
  Version                     : 50
  dwDpFlags                   : DNS_DP_AUTOCREATED DNS_DP_DOMAIN_DEFAULT DNS_DP_ENLISTED 
  pszDpFqdn                   : DomainDnsZones.firefly.michael.mol.name

  pszZoneName                 : _msdcs.firefly.michael.mol.name
  Flags                       : DNS_RPC_ZONE_DSINTEGRATED DNS_RPC_ZONE_UPDATE_SECURE 
  ZoneType                    : DNS_ZONE_TYPE_PRIMARY
  Version                     : 50
  dwDpFlags                   : DNS_DP_AUTOCREATED DNS_DP_FOREST_DEFAULT DNS_DP_ENLISTED 
  pszDpFqdn                   : ForestDnsZones.firefly.michael.mol.name


[1] It's registering A records of joined hosts seemingly fine, but it's not registering their AAAA records. But that's something I'm still looking into.
Comment 1 Kai Blin 2013-05-25 10:11:15 UTC
You need to create reverse records using either samba-tool dns or the DNS MMC tool from windows. This is just like in Microsoft's DNS server, and not a bug.
If there is a problem registering IPv6 records, please file a bug for that providing a network trace of the update failing.
Thank you.