Bug 9580 - Some global printer settings are not saved on Win7 but on XP
Some global printer settings are not saved on Win7 but on XP
Status: RESOLVED INVALID
Product: Samba 4.1 and newer
Classification: Unclassified
Component: Printing
4.1.7
x64 Windows 7
: P5 normal
: ---
Assigned To: printing-maintainers
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-21 20:29 UTC by Marc Muehlfeld
Modified: 2016-11-16 11:37 UTC (History)
1 user (show)

See Also:


Attachments
Screenshot of the dialoge on Win7 (70.88 KB, image/png)
2013-01-21 20:30 UTC, Marc Muehlfeld
no flags Details
Level 10 debug log (4.22 MB, application/octet-stream)
2013-01-21 20:31 UTC, Marc Muehlfeld
no flags Details
Level 10 debug logs + packet caputures (4.09 MB, application/octet-stream)
2013-05-28 14:31 UTC, Marc Muehlfeld
no flags Details
Level 10 Debug Log (Win 8.1) (204.20 KB, application/x-gzip)
2016-11-10 17:34 UTC, Marc Muehlfeld
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marc Muehlfeld 2013-01-21 20:29:42 UTC
We have several Sharp MX 2600n printers. We have uploaded postscript drivers for XP and Win7 64-Bit to our Samba server. All are preconfigured that the default output tray is the right one and not the middle one.

If I look at the settings I had configured on a XP machine, it's correct. If I open the properties on a Win7 64-Bit machine, it shows the middle tray (instead the right one). If I change the setting on Win7 as Domain Admin again to right, save and reopen the dialog, it's still 'middle'. If I change this value on XP and reopen the dialog, it's fine.

Also if users connect this printer on XP, it's correct (right), but Win7 users get the wrong (middle) as preconfigured default.

This problem also exists on 3.5.20.


Find attached a level 10 debug log that contains opening the printer settings as domain admin on a Win7 64-Bit machine, going to the 'extended' tab, clicking 'default values' and setting the value from 'middle' to 'right' and close all dialogs with 'OK'.
Comment 1 Marc Muehlfeld 2013-01-21 20:30:44 UTC
Created attachment 8460 [details]
Screenshot of the dialoge on Win7
Comment 2 Marc Muehlfeld 2013-01-21 20:31:38 UTC
Created attachment 8461 [details]
Level 10 debug log
Comment 3 Marc Muehlfeld 2013-01-21 20:48:17 UTC
I also retried it with the latest sharp drivers (1212a from 10.01.2013). Same problem.

Other values, like duplex, landscape/portrait, etc. also aren't saved on Win7. Only on XP.

I tried with Kyocera drivers (for FS-3920): Works like it should.
Comment 4 Marc Muehlfeld 2013-05-28 14:31:10 UTC
Created attachment 8929 [details]
Level 10 debug logs + packet caputures

Find attached each a level 10 debug log + network trace, that contains the following:
- Right-click to printer (on \\server\printer and faxes) -> Properties
- Click to 'advanced' tab
- Click to 'printing defaults' button
- click to 'paper' tab


It's the same printer and drivername. So the settings should be the same on both OS. But on Win7, the output tray ("Ausgabe") value is on it's default value ("Mittleres Papierfach") and isn't saved on changes, while on XP it shows the correct setting we had made ("Rechtes Papierfach"). It seems, that Win7 can't retrieve all the registry keys

Other settings we had configured, like the default input tray ("Papierzufuhr: LCT"), are the same on both OS, like it should.

I repeated the packet capture and level 10 debug log each twice for the above steps. But both times, logs and caputre were much bigger on XP than on Win7.


Also I included a level 10 debug log + packet caputure, of changing the output tray to "Rechtes Papierfach" and saving (what isn't saved or maybe can't be retrieved from the server, when reopening the dialog again).


Server is currently running 3.6.15.


Please let me know if I can provide you more information/logs/etc. to help to get this fixed.
Comment 5 Marc Muehlfeld 2014-05-14 07:39:11 UTC
Problem still exists in 4.1.7.
Setting product / version of this bug report to 4.1.7.
Comment 6 Andreas Schneider 2016-11-10 07:36:11 UTC
Please try to reproduce and provide new logs with a timestamp before you save the printer setting changes.

Please try also changing the OS version to:

spoolss:os_major = 5
spoolss:os_minor = 2
spoolss:os_build = 3790
Comment 7 Marc Muehlfeld 2016-11-10 17:34:25 UTC
Created attachment 12643 [details]
Level 10 Debug Log (Win 8.1)

I created a new level 10 debug log. It starts right before I saved the setting.
(Win 8.1, patch level Jun 2016)
Comment 8 Marc Muehlfeld 2016-11-10 17:38:24 UTC
I tried the settings from #c6, but this does not help.

By the way, the latest log uploaded in #c7 is based on Samba 4.5.1.
Comment 9 Andreas Schneider 2016-11-11 16:23:52 UTC
Where can I download that printer driver?
Comment 10 Marc Muehlfeld 2016-11-11 16:44:12 UTC
(In reply to Andreas Schneider from comment #9)
> Where can I download that printer driver?

http://www.sharp.de/cps/rde/xchg/de/hs.xsl/-/html/download-center.htm

Product: MX-2600N
Document type: Drivers
Emulators: PS

After starting the installer, the driver is unpacked. You find the PostScript driver in the "English\PS\*bit\" subdirectory.
Comment 12 Andreas Schneider 2016-11-15 16:17:01 UTC
I've looked into this with the Printer Driver installed.

If I right-click on the printer and then go to Configuration and change something there, I can see that it is saved on the Printing Server!

If I click on "Printing Preferences" then those changes seem to be local to the client. There is no change of configuration stored on the server. At least not for the paper dialog ...
Comment 13 Andreas Schneider 2016-11-15 16:21:15 UTC
Did you test with Windows 8.1 and a Windows Print Server.

Setup a client, make a snapshot. Configure the printer. Go back to the snapshot and check if the configuration is loaded from the print server.

I think we hunt a ghost here and simply the driver behaviour changed between versions ...
Comment 14 Marc Muehlfeld 2016-11-15 17:03:50 UTC
I tried this using the latest PS driver from Sharp with a Win 2012 R2 Print Server and Win 7 client and the problem is the same: Not all settings are stored and then retrieved from the client.

So you can close this BZ as INVALID.
Comment 15 Andreas Schneider 2016-11-16 11:37:38 UTC
Thanks Marc :)