Bug 9579 - samba-tool --must-change-at-next-login doesn't work
samba-tool --must-change-at-next-login doesn't work
Product: Samba 4.1 and newer
Classification: Unclassified
All All
: P5 normal
: ---
Assigned To: Andrew Bartlett
Samba QA Contact
Depends on:
Blocks: 11924
  Show dependency treegraph
Reported: 2013-01-21 13:52 UTC by Marc Muehlfeld
Modified: 2016-08-26 02:05 UTC (History)
1 user (show)

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Marc Muehlfeld 2013-01-21 13:52:09 UTC
I run:

# samba-tool user setpassword muehlfeld --must-change-at-next-login
New Password:
Changed password OK

Then I logged on Windows with my account (muehlfeld + new set password) and I wasn't forced to change my password.
Comment 1 Marc Muehlfeld 2014-05-14 07:31:47 UTC
Bug is still existing in 4.1.7.
Changing product / version of this bug report
Comment 2 leo.bernardi 2015-01-28 17:27:01 UTC
Hello All,

I have tested this situation with preview release 4.3.  This issue remains.  Situation is a password reset.

# /usr/local/samba/bin/samba-tool user setpassword USER1 --newpassword=ABC123abc  --must-change-at-next-login
Changed password OK

When I log in to a Linux server, the new password works but the user is not prompted to change the password.  The option --must-change-at-next-login works only when a new user is added.

The new password provided had not been used for the user previously.
Comment 3 Marc Muehlfeld 2016-08-26 02:05:37 UTC
I tried this in 4.5.0rc2 and I don't see this behaviour anymore. I'm closing this bug report.