Bug 957 - multibyte issue with line continuation character (\) in smb.conf
multibyte issue with line continuation character (\) in smb.conf
Status: RESOLVED DUPLICATE of bug 5959
Product: Samba 3.0
Classification: Unclassified
Component: Extended Characters
3.0.3
All All
: P3 trivial
: none
Assigned To: Alexander Bokovoy
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-10 21:43 UTC by TAKAHASHI Motonobu
Modified: 2008-12-16 09:50 UTC (History)
2 users (show)

See Also:


Attachments
sample smb.conf file (206 bytes, application/octet-stream)
2004-05-05 04:47 UTC, TAKAHASHI Motonobu
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description TAKAHASHI Motonobu 2004-01-10 21:43:22 UTC
Any line ending in a '\' is continued on the next line in smb.conf.

But this rule is also applied when a line is ended with '\' which is the 2nd 
byte of a multibyte character.
We should recognize whether the '\' is a '\' character or a 2nd (or 3rd) byte 
of a multibyte character.
Comment 1 Gerald (Jerry) Carter 2004-03-22 08:10:13 UTC
any feedback on this testing the 3.0.3pre1 release ?
Comment 2 TAKAHASHI Motonobu 2004-05-05 04:47:10 UTC
Created attachment 491 [details]
sample smb.conf file
Comment 3 TAKAHASHI Motonobu 2004-05-05 04:50:10 UTC
I tested on Samba 3.0.3 and found the bug was still reproduced.
I attached a sample smb.conf at #2.

(CP932 is supported on iconv() included in GNU libiconv.)
Comment 4 Gerald (Jerry) Carter 2005-02-08 21:48:01 UTC
I can't see this gettign fixed in 3.0. Sorry.
Comment 5 TAKAHASHI Motonobu 2008-12-16 09:49:57 UTC
Still not fixed in Samba 3.2.4
Comment 6 TAKAHASHI Motonobu 2008-12-16 09:50:42 UTC

*** This bug has been marked as a duplicate of 5959 ***