Bug 9553 - Cannot open certain files over local network
Cannot open certain files over local network
Status: RESOLVED WORKSFORME
Product: Samba 3.6
Classification: Unclassified
Component: File services
3.6.3
All Linux
: P5 normal
: ---
Assigned To: Volker Lendecke
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-09 22:44 UTC by flash872
Modified: 2013-01-10 18:25 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description flash872 2013-01-09 22:44:55 UTC
This may be related to existing bug 9519, but I'm not sure.

Please see, also, http://ubuntuforums.org/showthread.php?t=2095401&highlight=samba+libreoffice for a similar report.  (Mine is the bkaplan user entry in that discussion.)

I cannot open certain files for editing that are in my samba network shares (on my network file server running ubuntu 12.04 64-bit server edition, with terabyte raided drives). These share configurations are longstanding and have been trouble-free on my network, and they have not changed recently.

Although I can copy and move files, unopened, through the network via the samba share, and although I can open and edit pure text files in these shares, I have the same issues described in the above forum post when I try to open files in these samba shares with libreoffice--I'm getting a frozen splash screen and a hung application that has to be killed from the terminal. This happens with both libreoffice writer and spreadsheet documents. Once I get such a hang, I can no longer unmount the share. I did not observe this behavior happening until the last few days--previously, I was able to edit these same files in these same samba shares with no issues.

Interestingly, I can open and edit these same network files--with no problems--over an sftp: connection. Thus, I have convinced myself that it is not a problem with my Libreoffice installation and, rather, that it has something to do with samba.  If this bug should be posted also to the libreoffice bug system, kindly advise.

Here is my environment, but please ask for other needed details:

My server is a dual core machine with raided terabyte drives.  On it I'm running ubuntu 12.04LTS server 64-bit edition.  Samba config shows as version 2:3.6.3-2ubuntu2.3.

My client machines are all currently running Mint14 64-bit desktop edition.  All are at samba version 2:3.6.6-3ubuntu5.  All client machines have the above-described problems with samba share -based access.  No issues whatsoever over sftp connection.

Thanks.  Let me know how else I can help.

bkaplan
Comment 1 Björn Jacke 2013-01-10 18:25:08 UTC
some problem like these are fixed in the meantime. Please update to the latest 3.6 release. If Ubuntu doesn't offer them you can get them for Ubuntu LTS on enterprisesamba.org. If latest 3.6 doesn't work please reopen this bug and attach level 10 log files. Thanks for reporting!