Bug 9536 - Can't use Point'nPrint Drivers with Windows 8
Can't use Point'nPrint Drivers with Windows 8
Status: NEW
Product: Samba 3.6
Classification: Unclassified
Component: Printing
unspecified
All All
: P5 normal
: ---
Assigned To: printing-maintainers
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-03 16:50 UTC by soletan
Modified: 2013-11-21 12:18 UTC (History)
0 users

See Also:


Attachments
Logfile tracking Windows 8 x64 client trying to connect with printer share (167.33 KB, application/gzip)
2013-01-03 16:50 UTC, soletan
no flags Details
rpcclient trying to add version 4 driver (97.22 KB, application/gzip)
2013-01-03 16:51 UTC, soletan
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description soletan 2013-01-03 16:50:56 UTC
Created attachment 8378 [details]
Logfile tracking Windows 8 x64 client trying to connect with printer share

I've set up Samba v3.6.3 system providing print services to all current sorts of Windows clients. There is a driver provided by Samba for instant installation by connected clients. The setup works flawlessly with Windows XP 32bit, Windows 7 32/64 bit, but Windows 8 x64 fails to connect with printer due to lacking driver supported by server.

I tried to debug the case and used logfile at log level 10 tracing trials of Windows 8 to get driver information. Windows 8 was trying to open 

HKLM\SYSTEM\CurrentControlSet\Control\Print\Environments\Windows x64\Version-4

and 

HKLM\SYSTEM\CurrentControlSet\Control\Print\Environments\Windows x64\Version-2 

both missing actually.

I stumpled upon rpcclient adddriver providing opportunity to select version in a tailing optional parameter and so I tried to select version 4 on adding printer driver. This didn't succeed either and after using log level 10 I found Samba trying to be smart by fixing my selected version.

Basically Windows 8 is promoted to support drivers supported by Windows 7 as well. So I'd like to try faking Version-4 registry key but couldn't change Samba's registry using regedit remotely connected using printer admin account. That's obviously due to Samba faking several parts of registry mapping into special code.

Is it possible to add support for Version-4 drivers in Samba or is it known to not fixing issues with Windows 8 e.g. due to further incompatabilities?

Checked v3-6-stable branch of git and it's containing get_correct_cversion() forcing all Win x64 drivers to be considered Version-3.

Find attached both logfile tracking Windows 8 x64 client on trying to get any printer drivers and tracking rpcclient trying to add version 4 driver.
Comment 1 soletan 2013-01-03 16:51:32 UTC
Created attachment 8379 [details]
rpcclient trying to add version 4 driver
Comment 2 Frank Lascheit 2013-01-16 09:01:36 UTC
I stumbled upon this a while ago and managed to find the location in the sources causing the trouble and posted my 'fix' to the mailing list:

https://lists.samba.org/archive/samba/2012-December/170322.html

I hope this is helpful.
Comment 3 soletan 2013-01-21 09:33:15 UTC
(In reply to comment #2)
@Frank your approach is interesting as it's operating at the opposite side of the problem. I'd like to give it a try but using apt-src/dpkg-source/debuild on Ubuntu is having dependency issues I can't resolve myself currently. Thus I obviously might have to wait for an official fix or try yours in a few weeks to months again.
Comment 4 Arvid Requate 2013-11-21 12:18:04 UTC
This bug looks similar to this one: https://bugzilla.samba.org/show_bug.cgi?id=9474 , so maybe it's fixed? At least Point'n Print worked with Windows 8.1 joined to a Samba 4.1 (NT as well as AD-DC) the last time I checked.