Bug 953 - Service parameters in [global] is ignored if [global] appears after [share]
Service parameters in [global] is ignored if [global] appears after [share]
Status: RESOLVED WONTFIX
Product: Samba 3.0
Classification: Unclassified
Component: Config Files
3.0.1
All All
: P3 minor
: none
Assigned To: Samba Bugzilla Account
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-08 19:14 UTC by SATOH Fumiyasu
Modified: 2005-02-07 10:11 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description SATOH Fumiyasu 2004-01-08 19:14:37 UTC
I use 'include' paramter in a smb.conf to do test the Samba.
In some test case, [global] section appears in a smb.conf after [sharename]
section. However, Samba ignores service parameters in [global] section in this case.

For example, refere the following commands and outputs: 

$ cat smb.conf
[printer]
    printable = yes

[file]

[global]
    printing = sysv
    read only = no

$ testparm -s smb.conf
Load smb config files from smb.conf
Processing section "[printer]"
No path in service printer - using /tmp
Processing section "[file]"
No path in service file - using /tmp
Loaded services file OK.
# Global parameters
[global]
        read only = No
        printing = sysv

[printer]
        path = /tmp
        read only = Yes
        printable = Yes
        printing = bsd

[file]
        path = /tmp
        read only = Yes
        printing = bsd
Comment 1 Gerald (Jerry) Carter 2005-02-07 10:11:31 UTC
by design.  no plans to rewrite the smb.conf parser.