Bug 943 - Compile with Netscape LDAP SDK fails
Compile with Netscape LDAP SDK fails
Status: RESOLVED WONTFIX
Product: Samba 2.2
Classification: Unclassified
Component: User/Group Accounts
2.2.8a
All Solaris
: P3 normal
: ---
Assigned To: Gerald (Jerry) Carter
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-04 18:14 UTC by marco zhang
Modified: 2005-11-14 09:28 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description marco zhang 2004-01-04 18:14:18 UTC
Overview Description:
=====================

Compile with Netscape SDK fails with the following error:

Compiling passdb/pdb_ldap.c
passdb/pdb_ldap.c: In function `rebindproc_with_state':
passdb/pdb_ldap.c:276: error: `ldap_state' undeclared (first use in this function)
passdb/pdb_ldap.c:276: error: (Each undeclared identifier is reported only once


Steps to Reproduce:
===================
Compile in Solaris 9 with "./configure --with-ldapsam". Do not use openldap.
Solaris 9 comes with its own ldap SDK which is actually Netscape SDK

The reason for building Samba with Netscape SDK is to workaround the problem
whereby initgroups() system call fails to get supplmentary group from directory
server if compiles with OpenLdap and Native ldap client is enabled in Solaris.
Refer to the following discussion for this topic:

http://lists.samba.org/archive/samba-technical/2003-December/033162.html

To workaround this problem, I did this:

>- Modify <samba_source>/source/passdb/pdb_ldap.c, change line 276
>
>FROM:
>
>*whop = strdup(ldap_state->bind_dn);
>
>TO:
>
>*whop = strdup(lp_ldap_admin_dn());
Comment 1 Gerald (Jerry) Carter 2004-02-17 08:46:01 UTC
Sorry, but the 2.2 is not under development any longer.
If you can reproduce this bug against the latest 3.0 release, 
please reopen this bug and change the version in the report.
Thanks.
Comment 2 Gerald (Jerry) Carter 2005-11-14 09:28:34 UTC
database cleanup