Bug 9417 - Bad parameters to do provision
Bad parameters to do provision
Status: RESOLVED DUPLICATE of bug 9494
Product: Samba 4.0
Classification: Unclassified
Component: Documentation
unspecified
All Linux
: P5 critical
: ---
Assigned To: Samba Documentation QA Contact~
Samba Documentation QA Contact~
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-21 12:32 UTC by Adalberto Perez
Modified: 2012-12-31 05:50 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Adalberto Perez 2012-11-21 12:32:57 UTC
Regards,

I have a problem in the step 4 of the HOWTO (https://wiki.samba.org/index.php/Samba4/HOWTO) of samba4

I did run the provision with user root (all permission):

# /usr/local/samba/bin/samba-tool domain provision \
   --realm=samdom.example.com --domain=SAMDOM \
   --adminpass='p4$$word' --server-role=dc

in my case, the line is: /usr/local/samba/bin/samba-tool domain provision --realm=proxy.klarens.com.co --domain=KLARENS --adminpass='AdminKlarens2' --server-role=dc

But I have got the error:

ERROR(exceptions.TypeError): uncaught exception - __init__() got an unexpected keyword argument 'epilog'
  File "/usr/local/samba/bin/samba-tool", line 45, in ?
    retval = cmd._run("samba-tool", subcommand, *args)
  File "/usr/local/samba/lib64/python2.4/site-packages/samba/netcmd/__init__.py", line 201, in _run
    return self.subcommands[subcommand]._run(
  File "/usr/local/samba/lib64/python2.4/site-packages/samba/netcmd/__init__.py", line 201, in _run
    return self.subcommands[subcommand]._run(
  File "/usr/local/samba/lib64/python2.4/site-packages/samba/netcmd/__init__.py", line 142, in _run
    parser, optiongroups = self._create_parser(argv[0])
  File "/usr/local/samba/lib64/python2.4/site-packages/samba/netcmd/__init__.py", line 130, in _create_parser
    prog=prog,epilog=epilog)

I have prove several ways of to enter the commands, but the error always shows itself.

I wait by your response.

Thanks.
Comment 1 Andrew Bartlett 2012-12-31 05:50:48 UTC
Marking as duplicate of the bug Jelmer filed describing the actual source-level issue.

*** This bug has been marked as a duplicate of bug 9494 ***