Bug 9361 - Quotas management doesn't work with SMB2/3
Quotas management doesn't work with SMB2/3
Status: RESOLVED DUPLICATE of bug 11819
Product: Samba 4.1 and newer
Classification: Unclassified
Component: File services
All All
: P5 normal
: ---
Assigned To: Jeremy Allison
Samba QA Contact
Depends on:
  Show dependency treegraph
Reported: 2012-11-06 10:33 UTC by Stefan Metzmacher
Modified: 2016-04-13 21:15 UTC (History)
6 users (show)

See Also:

Patch for v4-0-test (return NOT_SUPPORTED) (1.10 KB, patch)
2012-11-06 10:33 UTC, Stefan Metzmacher
ambi: review+

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Metzmacher 2012-11-06 10:33:27 UTC
Created attachment 8157 [details]
Patch for v4-0-test (return NOT_SUPPORTED)

Quotas management doesn't work with SMB2/3

For now we'll just return NT_STATUS_NOT_SUPPORTED instead of

But we should really fix this later.
Comment 1 Stefan Metzmacher 2012-11-07 11:45:58 UTC
The not supported patch is a blocker for 4.0
Comment 2 Christian Ambach 2012-11-07 15:26:17 UTC
=> Karolin for 4.0-test
Comment 3 Karolin Seeger 2012-11-08 07:59:05 UTC
Pushed to autobuild-v4-0-test.
Comment 4 Karolin Seeger 2012-11-09 11:00:28 UTC
Pushed to v4-0-test.
Closing out bug report.

Comment 5 Stefan Metzmacher 2012-11-09 14:41:59 UTC
Reopen because we should implement the complete support,
which is already there for SMB1.
Comment 6 Stefan Metzmacher 2013-08-29 07:03:23 UTC
=> 4.2
Comment 7 Karolin Seeger 2013-12-10 15:39:25 UTC
Any news on this one?
Comment 8 Björn Jacke 2016-04-13 18:01:42 UTC
there was a patch posted on samba-technical for this:


Looks like you, Jeremy, already took a look a close at Partha's quota patches? Assigning to you :-)
Comment 9 Jeremy Allison 2016-04-13 21:15:38 UTC

*** This bug has been marked as a duplicate of bug 11819 ***