Bug 9314 - Logonscript isn't executed in some cases
Logonscript isn't executed in some cases
Status: RESOLVED WORKSFORME
Product: Samba 4.0
Classification: Unclassified
Component: File services
4.0.0rc5
x64 Windows XP
: P5 normal
: ---
Assigned To: Samba QA Contact
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-22 07:30 UTC by Marc Muehlfeld
Modified: 2013-05-28 14:33 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marc Muehlfeld 2012-10-22 07:30:25 UTC
We are running s4 (beta8, rc1, rc2 and since yesterday rc3) since about 6 weeks and we encountered, that every day sometimes the logonscript isn't executed.


In the machine logs I can see, that the client connects to the sysvol share, but not to netlogon. This is a example:

[2012/10/22 07:16:00.722892,  1, pid=102134] ../source3/smbd/service.c:902(make_connection_snum)
  10.1.0.254 (ipv4:10.1.0.254:1790) connect to service sysvol initially as user MUC\it-01$ (uid=600, gid=515) (pid 102134)
[2012/10/22 07:16:10.780658,  1, pid=102134] ../source3/smbd/service.c:1176(close_cnum)
  10.1.0.254 (ipv4:10.1.0.254:1790) closed connection to service sysvol
[2012/10/22 07:20:16.692120,  1, pid=103447] ../source3/smbd/service.c:902(make_connection_snum)
  10.1.0.254 (ipv4:10.1.0.254:1829) connect to service sysvol initially as user MUC\muehlfeld (uid=1061, gid=513) (pid 103447)
[2012/10/22 07:20:16.918401,  1, pid=103447] ../source3/smbd/service.c:902(make_connection_snum)
  10.1.0.254 (ipv4:10.1.0.254:1829) connect to service sysvol initially as user MUC\it-01$ (uid=600, gid=515) (pid 103447)
[2012/10/22 07:20:22.248068,  1, pid=103447] ../source3/smbd/service.c:1176(close_cnum)
  10.1.0.254 (ipv4:10.1.0.254:1829) closed connection to service sysvol
[2012/10/22 07:20:32.351279,  1, pid=103447] ../source3/smbd/service.c:1176(close_cnum)
  10.1.0.254 (ipv4:10.1.0.254:1829) closed connection to service sysvol


If the logonscript wasnt't executed and the user logoff/logon then everything is fine.


The problem for me to provide further logs is, that this happens just 2-3 times per day for our 150 users (and several logon/logoff multiple times per day). And the problem is not bind to a specific user or workstation.

If I set debug level to 10 in general, I'll create a huge amount of logs and flood my server. Are there just some debug classes I can set to 10 (or maybe lower) to capture what you require?
Comment 1 Marc Muehlfeld 2013-05-28 14:33:26 UTC
It seems that the problem was gone during the last versions. Meanwhile we don't have this problem any more.