Bug 9308 - Windows 7 reverse DNS update doesn`t work with bind 9.8
Windows 7 reverse DNS update doesn`t work with bind 9.8
Status: RESOLVED INVALID
Product: Samba 4.0
Classification: Unclassified
Component: DNS server
4.0.0rc1
All Windows 7
: P5 normal
: ---
Assigned To: Kai Blin
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-19 07:44 UTC by commiethebeastie
Modified: 2012-10-29 06:16 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description commiethebeastie 2012-10-19 07:44:22 UTC
Samba Version 4.1.0pre1-GIT-f4b9007 works as primary domain controller. We have windows XP, samba 3.6, samba 3.5 and windows 7 clients. Reverse zone DNS update is not work with windows 7.

But with Windows XP it`s just work:


[i]Oct 19 11:18:41 ldap named[10223]: samba_dlz: allowing update of signer=glbuch\$\@BLA.TLD name=122.0.168.192.in-addr.arpa tcpaddr= type=PTR key=1536-ms-7.8-c0b291.dcd55880-199f-11e2-8e82-5404a695b6b5/160/0
Oct 19 11:18:41 ldap named[10223]: samba_dlz: allowing update of signer=glbuch\$\@BLA.TLD name=122.0.168.192.in-addr.arpa tcpaddr= type=PTR key=1536-ms-7.8-c0b291.dcd55880-199f-11e2-8e82-5404a695b6b5/160/0
Oct 19 11:18:41 ldap named[10223]: client 192.168.0.122#54487: updating zone '0.168.192.in-addr.arpa/NONE': deleting rrset at '122.0.168.192.in-addr.arpa' PTR
Oct 19 11:18:41 ldap named[10223]: samba_dlz: subtracted rdataset 122.0.168.192.in-addr.arpa '122.0.168.192.in-addr.arpa.#0111200#011IN#011PTR#011Glbuch.bla.tld.'
Oct 19 11:18:41 ldap named[10223]: client 192.168.0.122#54487: updating zone '0.168.192.in-addr.arpa/NONE': adding an RR at '122.0.168.192.in-addr.arpa' PTR
Oct 19 11:18:41 ldap named[10223]: samba_dlz: added rdataset 122.0.168.192.in-addr.arpa '122.0.168.192.in-addr.arpa.#0111200#011IN#011PTR#011Glbuch.bla.tld.'
[/i]

[i]
/etc/bind/named.conf.local:

zone "168.192.in-addr.arpa" in {
        type master;
        file "dynamic/168.192.in-addr.arpa.zone";
check-names ignore;

        update-policy {
                grant *.INC wildcard *.0.168.192.in-addr.arpa. PTR;

        };
};

logging {
    channel query.log {
        file "/var/log/named/query.log";
        severity debug 9;
    };
    category queries { query.log; };
};
[/i]
Comment 1 commiethebeastie 2012-10-19 09:32:49 UTC
with Version 4.1.0pre1-GIT-bea7a25 this bug is st
Comment 2 commiethebeastie 2012-10-29 06:16:04 UTC
The behavior of Client not registering PTR record by default is modified prior to Windows7 (mostly during Vista time) and is the intended behavior. The Dhcp Server is responsible for performing PTR record registration on behalf of client. Incase if dynamic DNS registration is not enabled on Server (because of which Server doesnot do PTR registration), Client can trigger registration,if "Use this connection's DNS suffix in DNS registration" is selected in adapter properties.