Bug 9296 - Enabling winbind offline logon I can't access windows shares
Enabling winbind offline logon I can't access windows shares
Product: Samba 3.6
Classification: Unclassified
Component: Winbind
All All
: P3 major
: ---
Assigned To: Michael Adam
Samba QA Contact
Depends on:
  Show dependency treegraph
Reported: 2012-10-17 12:15 UTC by Piviul
Modified: 2013-11-11 10:40 UTC (History)
0 users

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Piviul 2012-10-17 12:15:25 UTC
If a machine is joined to a samba3 domain, winbind offline logon is enabled and
a domain user logs to the machine I expect than, using nautilus, the user can
access network shares without inserting the password again.

In samba 3.6.x the user can't access windows shares (I've tried shares hosted
on windows 2000 and windows xp). When the user access a windows share
nautilus ask for username and password and the authentication using the
credential of the current domain user fails even if the credentials are correct
(so authentication fails both using cached credentials or manual credentials).
Using different domain user credentials all seems to works.

This bug is not present in samba 3.5.x

Furthermore I have opened the same bug ubuntu (https://bugs.launchpad.net/ubuntu/+source/samba/+bug/1009419) and in debian (http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=690547); Christian Perrier suggested me to open it here instead of in debian or ubuntu bug tracking system.

Have a great day

Comment 1 Jeremy Allison 2012-10-17 12:23:25 UTC
Can you let us know the *exact* Samba 3.6 version you are running. I recently fixed an offline caching bug that this might be a duplicate of.


Comment 2 Piviul 2012-10-17 20:11:09 UTC
Yes of course! Samba 3.6.3 tested in ubuntu 12.04 and samba 3.6.6 tested in debian wheezy. Debian Squeeze (samba 3.5.6) is not affected by the bug.

Comment 3 Piviul 2013-07-22 08:35:27 UTC
I've just upgraded samba to 3.6.16 on a debian jessie (testing) and I can confirm that this bug is even present.

I've changed the priority to 3 hoping this bug will be solved soon because affect the use of windbind offline-logon: if you set winbind offline-logon  you can't access to windows shares using the same credentials used during log-on. 

Furthermore I see that this bug has status "needinfo": what info do you need? I can send you all infos you need to have this bug solved.

Have a great day

Comment 4 Piviul 2013-11-11 10:40:38 UTC
I have updated my debian jessie and samba has been upgraded to v. 4.0.10. SO I can confirm that the problem persist even in samba 4.0.10.

Please why you have marked the status with needinfo? What are the infos you need to find/solve the bug?