Bug 9294 - nmbd issues AIX 6.1 TL6 SP9
nmbd issues AIX 6.1 TL6 SP9
Status: RESOLVED DUPLICATE of bug 8984
Product: Samba 3.6
Classification: Unclassified
Component: Config Files
3.6.8
PPC AIX
: P5 normal
: ---
Assigned To: Jeremy Allison
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-16 17:32 UTC by Ed Sowinski
Modified: 2014-06-17 12:11 UTC (History)
1 user (show)

See Also:


Attachments
Output from running the configure command (config.log) (4.53 MB, text/plain)
2012-10-16 17:32 UTC, Ed Sowinski
no flags Details
Log of entire build process end to end (624.46 KB, text/plain)
2012-10-17 18:24 UTC, Ed Sowinski
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ed Sowinski 2012-10-16 17:32:32 UTC
Created attachment 8078 [details]
Output from running the configure command (config.log)

Trying to compile samba 3.6.8 on an IBM P770 running AIX 6.l Technology Level 6 Service Pack 9.

When the configure phase of the samba build process is run, numerous warning  messages are displayed.  When the make command is run, it fails with the stop message.

The config.log will be posted as an attachment to this bug report.

Here is the output from the make command:

root@inf-danitm /mnt/samba.3.6.8.src/samba-3.6.8/source3> make
Using CFLAGS     = -I../lib/zlib -O -I.  -I/mnt/samba.3.6.8.src/samba-3.6.8/source3  -I/mnt/samba.3.6.8.src/samba-3.6.8/source                               3/../lib/popt -I/mnt/samba.3.6.8.src/samba-3.6.8/source3/../lib/iniparser/src  -Iinclude -I./include  -I. -I. -I./../lib/repla                               ce -I./../lib/tevent -I./librpc -I./.. -I./../lib/talloc -I../lib/tdb/include  -DHAVE_CONFIG_H  -Iinclude -I./include -I. -I.                                -I./../lib/replace -I./../lib/tevent -I./librpc -I./.. -I./../lib/popt    -I/mnt/samba.3.6.8.src/samba-3.6.8/source3/lib  -I..                                 -D_SAMBA_BUILD_=3 -D_SAMBA_BUILD_=3
      PICFLAG    = -O2
      LIBS       =
      LDFLAGS    = -pie  -L./bin
      DYNEXP     = -Wl,-brtl,-bexpfull,-bbigtoc
      LDSHFLAGS  = -O2 -Wl,-G,-bexpfull,-bbigtoc,-brtl  -L./bin -lc -error_unresolved
      SHLIBEXT   = so
      SONAMEFLAG = #
Compiling ./../lib/replace/replace.c
In file included from ./../lib/replace/replace.c:26:
./../lib/replace/replace.h:464:1: warning: "mkstemp" redefined
In file included from ./../lib/replace/replace.h:40,
                 from ./../lib/replace/replace.c:26:
/opt/freeware/lib/gcc/powerpc-ibm-aix5.3.0.0/4.0.0/include/stdlib.h:467:1: warning: this is the location of the previous defin                               ition
In file included from ./../lib/replace/system/filesys.h:29,
                 from ./../lib/replace/replace.c:28:
/usr/include/unistd.h:924: error: parse error before '[' token
/usr/include/unistd.h:925: error: parse error before 'rid_t'
./../lib/replace/replace.c: In function 'rep_mkstemp':
./../lib/replace/replace.c:417: error: 'O_CREAT' undeclared (first use in this function)
./../lib/replace/replace.c:417: error: (Each undeclared identifier is reported only once
./../lib/replace/replace.c:417: error: for each function it appears in.)
./../lib/replace/replace.c:417: error: 'O_EXCL' undeclared (first use in this function)
./../lib/replace/replace.c:417: error: 'O_RDWR' undeclared (first use in this function)
The following command failed:

make: 1254-004 The error code from the last command is 1.


Stop.
root@inf-danitm /mnt/samba.3.6.8.src/samba-3.6.8/source3>
Comment 1 Jeremy Allison 2012-10-17 13:58:11 UTC
https://groups.google.com/forum/?hl=de&fromgroups=#!topic/comp.unix.aix/ZV1L_kVixNc

Says it might be a problem with the gcc install on your machine. The same error is found when compiling other Free Software on AIX.

The url above suggests :

"get a decently packaged gcc (from www.perzl.org e.g.)
compiles bzip2 just fine"

Can you try with a gcc install from there ?

Jeremy.
Comment 2 Ed Sowinski 2012-10-17 18:24:14 UTC
Created attachment 8082 [details]
Log of entire build process end to end


Re-ran the entire build process: autogen.sh, configure, make, make install and tried to startup the smbd and nmbd processes. Still see warnings & errors in configure and make phases.

The file samba.3.6.8.log is the output from the whole process start to finish.

It starts out at the top with the rpm's in use and goes thru each phase including failure to start smbd and nmbd.
Comment 3 Karolin Seeger 2012-10-18 07:13:33 UTC
Re-assigning to Jeremy.
Comment 4 Ed Sowinski 2012-10-18 12:49:46 UTC
Regarding "Log of entire build process end to end"  I upgraded gcc and its dependent software to the latest versions available from Mike Perzl's website (www.perzl.org)
Comment 5 Ed Sowinski 2012-10-18 18:55:25 UTC
I set the variable LIBPATH to /usr/local/samba/lib ( Korn shell export LIBPATH=/usr/local/samba/lib and was able to get the smbd daemon to start up.

I do have a problem starting the nmbd daemon.  Here is the log.nmbd log file.

I checked port 137 on my samba test system using the command lsof -Pni :137.  The port is unused.

[2012/10/18 14:41:11,  0] nmbd/nmbd.c:861(main)
  nmbd version 3.6.8 started.
  Copyright Andrew Tridgell and the Samba Team 1992-2011
[2012/10/18 14:41:11,  2] lib/tallocmsg.c:124(register_msg_pool_usage)
  Registered MSG_REQ_POOL_USAGE
[2012/10/18 14:41:11,  2] lib/dmallocmsg.c:78(register_dmalloc_msgs)
  Registered MSG_REQ_DMALLOC_MARK and LOG_CHANGED
[2012/10/18 14:41:11,  3] param/loadparm.c:9572(lp_load_ex)
  lp_load_ex: refreshing parameters
[2012/10/18 14:41:11,  3] param/loadparm.c:5192(init_globals)
  Initialising global parameters
[2012/10/18 14:41:11,  3] ../lib/util/params.c:550(pm_process)
  params.c:pm_process() - Processing configuration file "/etc/smb.conf"
[2012/10/18 14:41:11,  3] param/loadparm.c:8310(do_section)
  Processing section "[global]"
[2012/10/18 14:41:11,  3] nmbd/nmbd.c:383(reload_nmbd_services)
  services not loaded
[2012/10/18 14:41:11,  2] nmbd/nmbd.c:894(main)
  Becoming a daemon.
[2012/10/18 14:41:11,  3] nmbd/nmbd.c:963(main)
  Opening sockets 137
[2012/10/18 14:41:11,  3] nmbd/nmbd.c:733(open_sockets)
  open_sockets: Broadcast sockets opened.
[2012/10/18 14:41:11,  2] lib/interface.c:341(add_interface)
  added interface lo0 ip=127.0.0.1 bcast=127.255.254.191 netmask=
[2012/10/18 14:41:11,  2] lib/interface.c:341(add_interface)
  added interface en0 ip=198.28.170.101 bcast=198.28.170.239 netmask=
[2012/10/18 14:41:11,  3] lib/interface.c:310(add_interface)
  add_interface: not adding duplicate interface 198.28.170.101
[2012/10/18 14:41:11,  0] lib/util_sock.c:667(open_socket_in)
  bind failed on port 137 socket_addr = 198.28.170.239.
  Error = The socket name is not available on this system.
[2012/10/18 14:41:11,  0] nmbd/nmbd_subnetdb.c:127(make_subnet)
  nmbd_subnetdb:make_subnet()
    Failed to open nmb bcast socket on interface 198.28.170.239 for port 137.  Error was The socket name is not available on this system.
[2012/10/18 14:41:11,  0] nmbd/nmbd.c:975(main)
  ERROR: Failed when creating subnet lists. Exiting.
Comment 6 Björn Jacke 2014-06-17 12:11:14 UTC
looks like a dup of bug 8984. As the samba team has no AIX box we have no chance to work on this currently though. Feel free to donate a box :-)

*** This bug has been marked as a duplicate of bug 8984 ***