Bug 9291 - Make failing
Make failing
Status: RESOLVED DUPLICATE of bug 8732
Product: Samba 3.5
Classification: Unclassified
Component: Build environment
Sparc Solaris
: P5 normal
: ---
Assigned To: Karolin Seeger
Samba QA Contact
Depends on:
  Show dependency treegraph
Reported: 2012-10-15 20:30 UTC by Nitin Thakur
Modified: 2012-10-16 06:49 UTC (History)
0 users

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Nitin Thakur 2012-10-15 20:30:06 UTC
Solaris 10, SUNWspro12

Two problems to report

1) configure is unable to generate Makefile. I copied Makefile-noincludes to Makefile

2) No idea what to do with this one.
Linking bin/winbind_krb5_locator.so
Undefined                       first referenced
 symbol                             in file
socket                              ./../lib/replace/getifaddrs.o  (symbol belongs to implicit dependency /lib/libsocket.so.1)
getaddrinfo                         ../nsswitch/winbind_krb5_locator.o  (symbol belongs to implicit dependency /lib/libsocket.so.1)
freeaddrinfo                        ../nsswitch/winbind_krb5_locator.o  (symbol belongs to implicit dependency /lib/libsocket.so.1)
ld: fatal: symbol referencing errors. No output written to bin/winbind_krb5_locator.so
make: *** [bin/winbind_krb5_locator.so] Error 1

Although Makefile has: -
LIBREPLACE_LIBS=-lnsl -lsocket
Comment 1 Björn Jacke 2012-10-16 06:48:25 UTC
This is a DUPLICATE of 8732 which was about samba 3.6 only. Karo, can you please also pick 3085225e72c75abf84d7740334459cd971ee4c56 to 3.5 ?

*** This bug has been marked as a duplicate of bug 8732 ***