Bug 9249 - User name does not show up in cups log
User name does not show up in cups log
Status: RESOLVED FIXED
Product: Samba 4.0
Classification: Unclassified
Component: printing
4.0.0rc1
All All
: P5 major
: ---
Assigned To: printing-maintainers
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-06 00:34 UTC by greg long
Modified: 2012-10-06 14:02 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description greg long 2012-10-06 00:34:55 UTC
When printing the current user will show in the windows print queue status (in windows) but the user shows as unknown in log /var/log/cups/page_log

This breaks applications like papercut that need to know user info

These are being printed from server 2008

In samba 3 this works fine

A piece of cups config

<Printer ResourceRoomC>
AuthInfoRequired none
Info ResourceRoomC
DeviceURI ipp://10.0.1.215/printer
State Idle
StateTime 1348253332
Reason none-report
Type 4
Accepting Yes
Shared Yes
JobSheets none none
QuotaPeriod 0
PageLimit 0
KLimit 0
OpPolicy default
ErrorPolicy stop-printer



Version 4.1.0pre1-GIT-1bf209d

tail /var/log/cups/page_log
EastHallCopier 17 unknown [05/Oct/2012:18:48:57 -0500] 1 1 - localhost smbprn.bzgPIx - -
EastHallCopier 19 unknown [05/Oct/2012:19:01:07 -0500] 1 1 - localhost smbprn.LeZcW2 - -
WestHallCopier 20 unknown [05/Oct/2012:19:02:15 -0500] 1 1 - localhost smbprn.fDWe48 - -
Comment 1 greg long 2012-10-06 14:02:02 UTC
OK I got this fixed, but something is still wrong with current builds

I had to do what was in http://wiki.samba.org/index.php/Samba4/Winbind

ln -s /usr/local/samba/lib/libnss_winbind.so.2 /lib/libnss_winbind.so
ln -s /lib/libnss_winbind.so /lib/libnss_winbind.so.2

there was a winbind in /lib64 i think this is why the symbolic links were not created.

this was caused by winbind already being installed before install samba

samba-winbind-clients.x86_64


so i am closing this ticket