Bug 9152 - Incessant log messages from printer_list_get_printer: Failed to fetch record!
Incessant log messages from printer_list_get_printer: Failed to fetch record!
Status: RESOLVED DUPLICATE of bug 9112
Product: Samba 3.6
Classification: Unclassified
Component: Printing
3.6.7
Sparc Solaris
: P5 minor
: ---
Assigned To: printing-maintainers
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-10 23:34 UTC by Joseph Tam
Modified: 2012-09-11 12:50 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Joseph Tam 2012-09-10 23:34:39 UTC
Since upgrading samba to 3.6.*, I am getting incessant amounts
of log level 1 messages like this

        [2012/09/05 18:51:46.549449,  1] printing/printer_list.c:94(printer_list_get_printer)
          Failed to fetch record!
        [2012/09/05 18:51:46.555483,  1] printing/printer_list.c:94(printer_list_get_printer)
          Failed to fetch record!
        [2012/09/05 18:51:46.583850,  1] printing/printer_list.c:94(printer_list_get_printer)
          Failed to fetch record!
        [2012/09/05 18:51:46.589913,  1] printing/printer_list.c:94(printer_list_get_printer)
          Failed to fetch record!
        [2012/09/05 18:51:46.596250,  0] printing/printing.c:474(print_job_find)
          PANIC: assert failed at printing/printing.c(474): pjob->jobid == jobid
        [2012/09/05 18:51:46.604570,  0] printing/printing.c:474(print_job_find)
          PANIC: assert failed at printing/printing.c(474): pjob->jobid == jobid

This goes on and on and takes up the majority of my log file.  I can't
even find the debug class to selectively squelch these messages without
squelching everything in log level 1.  Printing, as far as I know,
remains functional.

What can I do to placate samba?

My printing specific configurations:

        # Disable automatic creation of printer shares
        #       - don't auto-load printers: manually declare them.
        #       - make sure printer list is empty anyways
        #       - do not update printcap cache; only do it on startup
        load printers = no
        printcap name = /dev/null
        printcap cache time = 0

        # Printer commands:
        #       - LPRng system (hints at how lpq is parsed)
        #       - explicitly remove spool files; more reliable.
        #       - change job owner to client (-U%U@%M) if LPRng allows it
        #               /var/lpd/etc/lpd.conf: allow_user_setting=smb
        #       - set job name (%J)
        #       - disable pause/resume commands, log them instead.
        printing = lprng
        print command = /usr/local/bin/lpr '-P%p' -U'%U@%M' '-J%J' '%s'; rm -f '%s'
        lprm command = /usr/local/bin/lprm '-P%p' '-U%U' '%j'
        lpq command = /usr/local/bin/lpq '-P%p'

        # Debug: log administrative request logs
        #lpq command = /usr/bin/logger -plocal3.info -t'smbd[%d]' 'Printer: %U@%I lpq %p'
        lppause command = /usr/bin/logger -plocal3.info -t'smbd[%d]' 'Printer: %U@%I paused job %p+%j'
        lpresume command = /usr/bin/logger -plocal3.info -t'smbd[%d]' 'Printer: %U@%I resumed job %p+%j'
        queuepause command = /usr/bin/logger -plocal3.info -t'smbd[%d]' 'Printer: %U@%I paused queue %p'
        queueresume command = /usr/bin/logger -plocal3.info -t'smbd[%d]' 'Printer: %U@%I resumed queue %p'

        # Performance tweaks
        #       - limit number of queued print jobs to avoid swamping.
        #       - cache lpq output for specified time for identical requests
        max print jobs = 32
        lpq cache time = 30

        # Workaround bug that disallows printing to non-printer administrator
        #       Ref: https://bugzilla.samba.org/show_bug.cgi?id=8769)
        #       - alternative: net rpc rights grant 'Everyone' SePrintOperatorPrivilege -S samba
        #printer admin = %U

        # Mysterious parameters that disables some more advanced printer
        # functions, especially with regards to printer driver support.
        disable spoolss = yes
        use client driver = yes
Comment 1 Andreas Schneider 2012-09-11 12:50:07 UTC

*** This bug has been marked as a duplicate of bug 9112 ***