Bug 9146 - Linux XFS quota support is not working
Linux XFS quota support is not working
Status: RESOLVED WONTFIX
Product: Samba 3.6
Classification: Unclassified
Component: File services
3.6.7
All Linux
: P5 normal
: ---
Assigned To: Karolin Seeger
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-07 16:15 UTC by Björn Jacke
Modified: 2013-04-30 04:39 UTC (History)
2 users (show)

See Also:


Attachments
backported fix for XFS quota support from master (3.79 KB, patch)
2012-09-07 16:15 UTC, Björn Jacke
no flags Details
fixed xfs quota patch for 3.6 (4.23 KB, patch)
2012-09-10 20:07 UTC, Björn Jacke
vl: review-
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Björn Jacke 2012-09-07 16:15:56 UTC
Created attachment 7863 [details]
backported fix for XFS quota support from master

XFS quota support did not work at all. The attached patch is a backport of the fix in master. This should go into the next 3.6 release.
Comment 1 Volker Lendecke 2012-09-10 18:35:47 UTC
My deep apologies for not being quick enough. I spent the whole day on a customer defect and now I am trying to figure out how to enable this patch. --with-quotas=yes was not sufficient, now I am trying both --with-quotas=yes and --with-sys-quotas=yes. Again, sorry for not doing instant review.
Comment 2 Volker Lendecke 2012-09-10 18:36:51 UTC
How on earth can I activate this freaking code???? --with-quotas=yes and --with-sys-quotas=yes does not work on sn-devel.
Comment 3 Björn Jacke 2012-09-10 20:07:42 UTC
Created attachment 7871 [details]
fixed xfs quota patch for 3.6

sorry, the problem is if you touch something in the 3.6 quota tests, everything else blows up also. This corrected patch now moved the actual linux-xfs test to the end of the quota patches which makes it work for me now. In addition to that this looks like the minimal aproach to me which should not touch any of the other quota stuff.
Comment 4 Volker Lendecke 2012-09-11 06:24:47 UTC
Comment on attachment 7871 [details]
fixed xfs quota patch for 3.6

For the very reason you state "everything else blows up", I give this a -. We will never be able to go through all supported platforms and make sure that they do not break. This is not fixable in any reasonable amount of time.
Comment 5 Volker Lendecke 2012-09-11 06:25:29 UTC
Sorry, this has given me enough headaches that I am not willing to spend any more time on it.
Comment 6 Stefan Gohmann 2013-04-30 04:39:18 UTC
(In reply to comment #3)
> Created attachment 7871 [details]
> fixed xfs quota patch for 3.6
> 
> sorry, the problem is if you touch something in the 3.6 quota tests, everything
> else blows up also. This corrected patch now moved the actual linux-xfs test to
> the end of the quota patches which makes it work for me now. In addition to
> that this looks like the minimal aproach to me which should not touch any of
> the other quota stuff.

We had a similar report that Samba 3.6.8 with XFS and quota does not work properly with our Debian based distribution. After applying the patch and rebuild Samba it seems to work but I have currently only tested Samba 3 and XFS.

I will also test Samba 4 and check both Samba versions with ext3 / ext4. Can I do anything more to get the patch upstream?

Thanks
Stefan