Bug 9140 - Permissions for GPO in the SYSVOL folder are inconsistent with those in Active Directory
Permissions for GPO in the SYSVOL folder are inconsistent with those in Activ...
Status: RESOLVED DUPLICATE of bug 9342
Product: Samba 4.0
Classification: Unclassified
Component: AD: LDB/DSDB/SAMDB
4.0.0rc3
x64 Linux
: P5 normal
: ---
Assigned To: Andrew Bartlett
samba4-qa@samba.org
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-06 07:04 UTC by Marc Muehlfeld
Modified: 2013-01-04 13:59 UTC (History)
2 users (show)

See Also:


Attachments
Level 10 debug log (111.21 KB, application/x-bzip2)
2012-09-06 07:04 UTC, Marc Muehlfeld
no flags Details
Screenshot of the error message (42.97 KB, image/png)
2012-09-06 07:05 UTC, Marc Muehlfeld
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marc Muehlfeld 2012-09-06 07:04:56 UTC
Created attachment 7860 [details]
Level 10 debug log

I've migrated our s3 production to s4 beta8 several times in my test environment and everytimes the following appeared:

If I open the group policy management console, go to 'domains' / '-myDomain-' / 'Group Policy Objects' and click to any of the entries, a message appears:

> The permissions for this GPO in the SYSVOL folder are inconsistent
> with those in Active Directory. It is recommended that these permissions
> be consistent. To change the SYSVOL permissions to those in Active
> Directory, click OK.
> For more information, see the Microsoft Knowledge Base article: 
> http://go.microsoft.com/fwlink/?LinkId=20066

I'm not sure if I had this also the first time I opened the console. So maybe this message start appearing after I setup a first group policy.

I attached a level 10 debug log from the AD controller when I clicked to 'Default Domain Controller Policy'.
Comment 1 Marc Muehlfeld 2012-09-06 07:05:26 UTC
Created attachment 7861 [details]
Screenshot of the error message
Comment 2 Marc Muehlfeld 2012-09-24 10:17:17 UTC
I have the same after I switched to rc1.

After the switch I run 'samba-tool ntacl sysvolreset'. But the message on windows is still there, when clicking to a GPO.
Comment 3 Torsten 2012-10-15 07:50:45 UTC
This problem looks similar like #5483
Comment 4 Stefan Metzmacher 2012-11-07 12:05:36 UTC

*** This bug has been marked as a duplicate of bug 9342 ***
Comment 5 Marc Muehlfeld 2012-12-04 19:01:11 UTC
rc6 fixes this issue. Thanks.
Comment 6 akarthikeyan 2013-01-03 11:42:59 UTC
(In reply to comment #5)
> rc6 fixes this issue. Thanks.

Similar kind of problem we are facing in Samba 3.6. 
We would like to know whether the fix available in Samba 3.6 or not ?
Comment 7 Stefan Metzmacher 2013-01-04 13:59:27 UTC
(In reply to comment #6)
> (In reply to comment #5)
> > rc6 fixes this issue. Thanks.
> 
> Similar kind of problem we are facing in Samba 3.6. 
> We would like to know whether the fix available in Samba 3.6 or not ?

Please file a new bug report with a detailed description of the problem
in 3.6. It's most likely not related to this bug report.