Bug 9122 - winreg_printer_openkey: Could not open HKLM hive: NT_STATUS_RPC_PROCNUM_OUT_OF_RANGE
winreg_printer_openkey: Could not open HKLM hive: NT_STATUS_RPC_PROCNUM_OUT_O...
Status: RESOLVED FIXED
Product: Samba 3.6
Classification: Unclassified
Component: Printing
3.6.7
x64 Linux
: P5 normal
: ---
Assigned To: Karolin Seeger
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-28 12:41 UTC by Marc Muehlfeld
Modified: 2012-08-29 08:31 UTC (History)
1 user (show)

See Also:


Attachments
snippet from smbd.log (2.46 KB, text/plain)
2012-08-28 12:44 UTC, Marc Muehlfeld
no flags Details
v3-6-test patch (1.28 KB, patch)
2012-08-28 12:55 UTC, Andreas Schneider
ddiss: review+
asn: review? (gd)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marc Muehlfeld 2012-08-28 12:41:02 UTC
When migrating from 3.5.17 to 3.6.7, I get several of the following messages in smbd.log:

[2012/08/28 14:40:29.899625,  0, pid=31662] rpc_client/cli_winreg_spoolss.c:241(winreg_printer_openkey)
  winreg_printer_openkey: Could not open HKLM hive: NT_STATUS_RPC_PROCNUM_OUT_OF_RANGE


This message appears 28 times (I have 27 printers defined). Don't know, if this matters.
Comment 1 Marc Muehlfeld 2012-08-28 12:44:37 UTC
Created attachment 7840 [details]
snippet from smbd.log
Comment 2 Andreas Schneider 2012-08-28 12:55:33 UTC
Created attachment 7841 [details]
v3-6-test patch
Comment 3 Andreas Schneider 2012-08-28 12:59:03 UTC
What the log file shows is that it is trying to migrate the printers from the 3.5 printing tdbs to winreg. The problem is that there is no winreg pipe set up yet.
Comment 4 David Disseldorp 2012-08-28 14:47:03 UTC
Comment on attachment 7841 [details]
v3-6-test patch

Looks good as a follow up to 3bdcf3208c8ff1a99bc457549257af83a869b381.
Comment 5 Andreas Schneider 2012-08-28 14:56:32 UTC
Karolin, please add it to the next 3.6 release.
Comment 6 Karolin Seeger 2012-08-29 07:20:34 UTC
(In reply to comment #4)
> Comment on attachment 7841 [details]
> v3-6-test patch
> 
> Looks good as a follow up to 3bdcf3208c8ff1a99bc457549257af83a869b381.

3bdcf3208c8ff1a99bc457549257af83a869b381 is not in v3-6-test.
If it should be added also, please attach it to this bug report and set the review flag. Thanks!
Comment 7 Karolin Seeger 2012-08-29 08:31:52 UTC
After talking to Andreas, pushed patch to v3-6-test.
3bdcf3208c8ff1a99bc457549257af83a869b381 is not needed.
Closing out bug report.

Thanks!