Bug 9077 - [4.0 beta5] compile error in pyldb.c: NULL format string
[4.0 beta5] compile error in pyldb.c: NULL format string
Status: NEEDINFO
Product: Samba 4.0
Classification: Unclassified
Component: Build
unspecified
x86 FreeBSD
: P5 normal
: ---
Assigned To: Andrew Bartlett
samba4-qa@samba.org
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-03 12:12 UTC by Christoph Theis
Modified: 2012-08-11 21:36 UTC (History)
0 users

See Also:


Attachments
make log (2.04 KB, application/octet-stream)
2012-08-03 12:12 UTC, Christoph Theis
no flags Details
configure log (zipped) (297.47 KB, application/octet-stream)
2012-08-03 12:41 UTC, Christoph Theis
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christoph Theis 2012-08-03 12:12:36 UTC
Created attachment 7737 [details]
make log

Compiling beta5 and HEAD (master) I get a compile error:
.../lib/ldb/pyldbc.:1833 null format string

config.log and make.log (with waf -vv) are attached.

I don't have ldb installed from ports. But I can't find the error message in the samba source tree, either ...

It worked with beta4.

[How do I attach 2 files at the same time?]
Comment 1 Christoph Theis 2012-08-03 12:41:18 UTC
Created attachment 7738 [details]
configure log (zipped)
Comment 2 Volker Lendecke 2012-08-03 21:12:51 UTC
Same here. Just revert 3aa6f085c22ce33ead23f7ebb604be5525759eee from your checkout and everything is fine.
Comment 3 Andrew Bartlett 2012-08-06 21:50:33 UTC
Should be fixed by 33c79c8731ea0c1ab78583a7c50953c56aea539f
Comment 4 Christoph Theis 2012-08-11 18:47:32 UTC
I updated to master today. Now I get the same error (NULL format string) at lib/ldb/ldb_map/ldb_map.c:1018
Comment 5 Andrew Bartlett 2012-08-11 21:36:34 UTC
Since I first 'fixed' this, I realised that a NULL pointer here is a perfectly legitimate (if unusual) use of the API, and so I tried another approach:  Only failing other format string errors on compilers that will support a NULL pointer here.

The issue is that the example at the end of bin/config.log and specified in buildtools/wafsamba/samba_autoconf.py succeeds, while the runtime fails.

If you have time, it would be great if you could find me an example that fails at configure time, so I can detect this right.

It might be as simple as testing -Wformat=2 or -Wformat-security at the same time, or something about the C snippet. 

Any assistance you can provide here would be most helpful. 

Thanks,