Bug 906 - Win XPPro Domain Logon Fails
Summary: Win XPPro Domain Logon Fails
Status: CLOSED FIXED
Alias: None
Product: Samba 3.0
Classification: Unclassified
Component: Domain Control (show other bugs)
Version: 3.0.1
Hardware: All Windows XP
: P1 normal
Target Milestone: none
Assignee: Gerald (Jerry) Carter
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-12-19 16:58 UTC by John H Terpstra (mail address dead(
Modified: 2005-11-14 09:24 UTC (History)
0 users

See Also:


Attachments
Samba Logs level 10, Windows XP Diagnositic Debug Info (141.39 KB, application/octet-stream)
2003-12-19 17:02 UTC, John H Terpstra (mail address dead(
no flags Details
Ethereal Captures of Join, reboot, logon attempt. (65.57 KB, application/octet-stream)
2003-12-23 14:24 UTC, John H Terpstra (mail address dead(
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description John H Terpstra (mail address dead( 2003-12-19 16:58:15 UTC
Windows XP Pro - SP1, latest On-Line update fails to logon to Domain after
successfully joining the domain.

The domain member machine account is correctly created in the LDAP backend.

The failure appears to be caused by a problem with NTLMSSP processing.

Dec 01, 2003: CVS check out works - even though it too has NTLMSSP problems
with machine account password validation.

Dec 18, 2003 - 8pm MST: Does not allow the client to log on at all.

This is a blocker level bug.
Comment 1 John H Terpstra (mail address dead( 2003-12-19 17:02:01 UTC
Created attachment 332 [details]
Samba Logs level 10, Windows XP Diagnositic Debug Info

The attached tarball contains:

For both CVS-2003-12-01 and CVS-2003-12-18 (3.0 Branch):

Samba level 10 logs for IP Addr. 192.168.2.253, Host: vaioboss$
Ethereal Caps for:
	- Join Domain
	- Logon attempt (2X in case of fail)
Windows XPP Debug Logs for NetSetup.txt

PS: Is this enough information?
Comment 2 John H Terpstra (mail address dead( 2003-12-23 14:24:54 UTC
Created attachment 338 [details]
Ethereal Captures of Join, reboot, logon attempt.

Network Caputers
Comment 3 John H Terpstra (mail address dead( 2003-12-23 14:26:03 UTC
Sorry. I left off the captures previously.
Comment 4 Andrew Bartlett 2003-12-31 18:47:52 UTC
I fixed this - was indeed caused by bugs in my NTLMSSP changes.
Comment 5 Gerald (Jerry) Carter 2005-08-24 10:15:53 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.
Comment 6 Gerald (Jerry) Carter 2005-11-14 09:24:46 UTC
database cleanup