Bug 9046 - Undefined symbol when executing smbd -D
Undefined symbol when executing smbd -D
Status: RESOLVED FIXED
Product: Samba 3.6
Classification: Unclassified
Component: File services
3.6.2
x86 Linux
: P5 critical
: ---
Assigned To: Volker Lendecke
Samba QA Contact
:
: 9076 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-16 07:54 UTC by Peter Sanders
Modified: 2012-08-07 16:58 UTC (History)
1 user (show)

See Also:


Attachments
Log file from './configure' stage of source compile process (3.66 MB, text/plain)
2012-07-16 07:54 UTC, Peter Sanders
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Sanders 2012-07-16 07:54:58 UTC
Created attachment 7706 [details]
Log file from './configure' stage of source compile process

when the '/etc/rc.d/rc.samba start' script is executed, smbd execution is cut short and an 'undefined symbol' message appears in log.smb

Here's an excerpt from log.smb
**************************************
  bilbo (::ffff:192.168.0.19) connect to service public.cd2 initially as user pete (uid=101, gid=100) (pid 12828)
[2012/07/16 16:57:48.461609,  1] smbd/service.c:1070(make_connection_snum)
  bilbo (::ffff:192.168.0.19) connect to service public.cd1 initially as user pete (uid=101, gid=100) (pid 12828)
[2012/07/16 16:57:48.466784,  1] smbd/service.c:1070(make_connection_snum)
  bilbo (::ffff:192.168.0.19) connect to service public.cd0 initially as user pete (uid=101, gid=100) (pid 12828)
[2012/07/16 16:57:48.471933,  1] smbd/service.c:1070(make_connection_snum)
  bilbo (::ffff:192.168.0.19) connect to service public.tek initially as user pete (uid=101, gid=100) (pid 12828)
[2012/07/16 16:57:48.477130,  1] smbd/service.c:1070(make_connection_snum)
  bilbo (::ffff:192.168.0.19) connect to service public.win initially as user pete (uid=101, gid=100) (pid 12828)
[2012/07/16 16:57:48.482408,  1] smbd/service.c:1070(make_connection_snum)
  bilbo (::ffff:192.168.0.19) connect to service public.dos initially as user pete (uid=101, gid=100) (pid 12828)
[2012/07/16 16:57:48.491161,  1] smbd/service.c:1070(make_connection_snum)
  bilbo (::ffff:192.168.0.19) connect to service games initially as user guest (uid=301, gid=300) (pid 12828)
[2012/07/16 17:37:33.920897,  1] param/loadparm.c:7992(lp_do_parameter)
  WARNING: The "null passwords" option is deprecated
[2012/07/16 17:37:33.921427,  1] param/loadparm.c:6811(map_parameter)
  Unknown parameter encountered: "allow insecure symlinks"
[2012/07/16 17:37:33.921465,  0] param/loadparm.c:7969(lp_do_parameter)
  Ignoring unknown parameter "allow insecure symlinks"
[2012/07/16 17:37:33.921522,  0] param/loadparm.c:8004(lp_do_parameter)
  Global parameter unix extensions found in service section!
/usr/local/samba/sbin/smbd: symbol lookup error: /usr/local/samba/sbin/smbd: undefined symbol: wbcSidsToUnixIds
[2012/07/16 17:42:39.042719,  1] param/loadparm.c:6494(map_parameter)
  Unknown parameter encountered: "allow insecure symlinks"
[2012/07/16 17:42:39.042763,  0] param/loadparm.c:7588(lp_do_parameter)
  Ignoring unknown parameter "allow insecure symlinks"
[2012/07/16 17:42:39.042802,  0] param/loadparm.c:7617(lp_do_parameter)
  Global parameter unix extensions found in service section!
[2012/07/16 17:42:42.188567,  0] smbd/server.c:500(smbd_open_one_socket)
  smbd_open_once_socket: open_socket_in: Address already in use
[2012/07/16 17:42:42.188686,  0] smbd/server.c:500(smbd_open_one_socket)
  smbd_open_once_socket: open_socket_in: Address already in use
Comment 1 Volker Lendecke 2012-07-16 08:19:35 UTC
Install the newly compiled libwbclient into the appropriate place
Comment 2 Peter Sanders 2012-07-16 09:06:05 UTC
This same problem occurs with 3.6.6 also.

System is Linux 2.6.33 from a Slackware distribution compiled with Gnu C++ 4.4

(In reply to comment #1)
> Install the newly compiled libwbclient into the appropriate place

Does libwclient not self install when I execute 'make install'?

If not, where is the appropriate place? I am using all the default file locations.
Comment 3 Volker Lendecke 2012-07-16 09:09:36 UTC
No, libwbclient does not install itself, as the normal linker would not find it under /usr/local/samba/lib. If you do a "ldd /usr/local/samba/sbin/smbd", you will find a line that contains the string "libwbclient". That will point you at the location that your system has installed the existing libwbclient into. You will need to copy bin/libwbclient.so into that location.
Comment 4 Peter Sanders 2012-07-16 09:26:15 UTC
Copying libwclient.so.0 from /usr/local/samba/lib to /usr/lib fixed the problem.
Comment 5 Björn Jacke 2012-08-07 16:58:09 UTC
*** Bug 9076 has been marked as a duplicate of this bug. ***