Bug 9005 - How to optimize code size & memory requirement for embedded platform
How to optimize code size & memory requirement for embedded platform
Status: RESOLVED INVALID
Product: Samba 3.6
Classification: Unclassified
Component: Build environment
3.6.5
All Linux
: P1 normal
: ---
Assigned To: Björn Jacke
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-25 06:26 UTC by sss
Modified: 2012-06-26 08:21 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sss 2012-06-25 06:26:04 UTC
Dear Team,

We want to port the Samba server to STLinux based embedded platform. Due to huge memory requirement we are bit struggling to use it. 

As per our understanding Samba is already optimized for embedded platforms.

What are the memory level optimization done for embedded platforms & Any other details avail relate to this.

Please help us.

Best Regards,
Vicky.
Comment 1 Björn Jacke 2012-06-25 10:32:56 UTC
first of all: this is not a blocker. second: this is not a bug report but a question. As bugzilla is not a discussion forum but a bug tracker I close this as invalid. Sorry, please ask stuff like this on the mailing list, e.g. samba-technical.
Comment 2 sss 2012-06-25 11:29:21 UTC
(In reply to comment #1)
> first of all: this is not a blocker. second: this is not a bug report but a
> question. As bugzilla is not a discussion forum but a bug tracker I close this
> as invalid. Sorry, please ask stuff like this on the mailing list, e.g.
> samba-technical.

OK, Thanks for your feed back.
Comment 3 sss 2012-06-26 06:03:29 UTC
Dear Jacke,

Sorry for the incontinent,

I entered my comments on mailing list.

But I didn't get any response.

Can you please help me.

Best Regards,
Vicky.
Comment 4 sss 2012-06-26 06:07:10 UTC
(In reply to comment #3)
> Dear Jacke,
> 
> Sorry for the incontinent,
> 
> I entered my comments on mailing list.
> 
> But I didn't get any response.
> 
> Can you please help me.
> 
> Best Regards,
> Vicky.

Code(binary) size is nearly 11 MB(smbd+smbpasswd). Is any possible to reduce it.