Bug 8977 - iscsi will not start
iscsi will not start
Status: RESOLVED FIXED
Product: CTDB 2.5.x or older
Classification: Unclassified
Component: ctdb
unspecified
All Linux
: P5 regression
: ---
Assigned To: Amitay Isaacs
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-05 08:10 UTC by Dan
Modified: 2013-10-03 01:22 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dan 2012-06-05 08:10:34 UTC
In latest git, please add "loadconfig" to config/events.d/70.iscsi

OMG It took me 2 hours to figure this out.

Also, I changed the following line because, though both systems are Centos 6.2 x86_64, `ctdb ip` shows different results.
node1: 127.0.0.1 0
node2: 127.0.0.1 node[0]

#for NODE in `ctdb ip | grep -v "Public" | egrep " ${THIS_NODE}$" | sed -e "s/ .*//"`; do
for NODE in `ctdb ip -Y|grep ":$THIS_NODE:"|cut -d : -f 2`; do

Thanks.
Dan
Comment 1 Amitay Isaacs 2013-10-03 01:22:53 UTC
This has been fixed upstream.  It will be in CTDB 2.5 release.