Bug 8941 - Solved problem with hard links and schg flag
Solved problem with hard links and schg flag
Status: NEW
Product: rsync
Classification: Unclassified
Component: core
3.0.9
All FreeBSD
: P5 major
: ---
Assigned To: Wayne Davison
Rsync QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-14 17:23 UTC by Franz Schwartau
Modified: 2012-05-14 17:23 UTC (History)
0 users

See Also:


Attachments
Patch for syscall.c (793 bytes, text/plain)
2012-05-14 17:23 UTC, Franz Schwartau
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Franz Schwartau 2012-05-14 17:23:37 UTC
Created attachment 7559 [details]
Patch for syscall.c

Hi!

Using rsync under FreeBSD with hard links and files having schg set result in EPERM "Operation not permitted". This behavior can be observed if rsyncing /usr/bin/.

The patch fileflags.diff tries to deal with this situation but changes the flags of the parent directory only. It doesn't change the flags of the files itself.

do_link() in syscall.c has to be fixed. patch-syscall.c.txt is a patch which have the be applied after fileflags.diff.

Best regards
Franz