Bug 8895 - rsync warning: some files vanished
rsync warning: some files vanished
Status: RESOLVED INVALID
Product: rsync
Classification: Unclassified
Component: core
3.0.9
x86 Linux
: P5 major
: ---
Assigned To: Wayne Davison
Rsync QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-25 19:03 UTC by Toralf Förster
Modified: 2012-04-25 20:28 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster 2012-04-25 19:03:21 UTC
Today I got this message - for the first time as far I can remember :

rsync warning: some files vanished before they could be transferred (code 24) at main.c(1052) [sender=3.0.9]

It happens at an almost stable Gentoo with kernel 3.3.3, booted from an external USB disk.

The rsync backup's from that external USB disk to another luks-encrypted USB disk using these parameters :

--archive --cvs-exclude --delete --delete-excluded --devices --include-from=/include.list --exclude-from=/exclude.list --itemize-changes --link-dest=$REF

BTW it was the first time, that I accessed the backup disk not directly as /dev/sdc1, instead I used /dev/disk/by-uuid/<uuid>
I do the backup nearly daily, so with the given $REF (the directory from the day before) rsync mostly has to make hard links at the external USB disk.

FWIW the system was under load (~5-6), b/c I run in parallel a compile job (make -j 2) and was within the dokcing station, all USB disks were atatched directly to the notebook.
Comment 1 Kevin Korb 2012-04-25 19:09:21 UTC
This warning happens whenever rsync sees a file during the indexing phase but by the time it gets around to actually copying the file it is no longer there (as in something else deleted it).

This is most common on things like email spools but I can see a compile job causing it as well.

Usually it can be safely ignored. However, you should look higher in the output as rsync should have said what file(s) vanished.

The path to the device that you mounted would not matter to rsync.
Comment 2 Toralf Förster 2012-04-25 19:32:03 UTC
Ah - thx, therefore not a bug (but then I must mis the line with the vanished file name ...)

BTW do you know, whether a special return code is used in this case ? Then I could catch this special case.
Comment 3 Kevin Korb 2012-04-25 19:44:54 UTC
Yes, exit code 24.
Comment 4 Toralf Förster 2012-04-25 20:28:49 UTC
thx