Bug 886 - Cannot create group using smbldap-groupadd tool
Cannot create group using smbldap-groupadd tool
Status: CLOSED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: User/Group Accounts
3.0.0preX
All Linux
: P2 major
: none
Assigned To: Samba Bugzilla Account
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-15 08:26 UTC by bao quoc phan
Modified: 2005-11-14 09:30 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bao quoc phan 2003-12-15 08:26:14 UTC
I was using Samba 3.0 rc1, and smbldap tools version 0.8.1, and the LDAP server
is IBM Directory Server 5.1. 

The problem is when I tried to create a group by issued the command at the shell
prompt: #smbldap-groupadd.pl nwgrp, I got the error said: Invalid syntax at
/usr/local/sbin/smbldap_tools.pm line 180. I opened the smbldap_tools.pm, and
saw an issue with the code.

First of all, the code is:
filter=>"(&(objectclass=posixGroup")(!(cn=$group)(gidNumber=$group)))"

According to the LDAP schema gidNumber is numeric only. But the value which
passed from smbldap-groupadd is alpha-nummeric (in this case the value is
nwgrp). Eventhough there is the OR sign "!", but the value will always assign to
gidNumber when the users try to create a new group. 

Thanks,
Comment 1 Gerald (Jerry) Carter 2004-04-22 20:08:00 UTC
newer version of tools available.  please reopen if still an issue.
Comment 2 Gerald (Jerry) Carter 2005-02-07 09:05:21 UTC
originally reported against one of the 3.0.0rc[1-4] releases.
Cleaning up non-production versions.
Comment 3 Gerald (Jerry) Carter 2005-08-24 10:19:13 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.
Comment 4 Gerald (Jerry) Carter 2005-11-14 09:30:10 UTC
database cleanup