Bug 8833 - Files of type DST are R/W only for file owner
Files of type DST are R/W only for file owner
Status: NEW
Product: Samba 3.5
Classification: Unclassified
Component: User & Group Accounts
All All
: P5 normal
: ---
Assigned To: Samba Bugzilla Account
Samba QA Contact
Depends on:
  Show dependency treegraph
Reported: 2012-03-29 18:57 UTC by JC Lambert
Modified: 2012-07-11 18:56 UTC (History)
2 users (show)

See Also:

except from the SMB.conf file for the share in question (215.78 KB, image/jpeg)
2012-03-29 18:57 UTC, JC Lambert
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description JC Lambert 2012-03-29 18:57:11 UTC
Created attachment 7411 [details]
except from the SMB.conf file for the share in question

I have been able to recreate this with default installs on Samba 3.5.10 and 3.5.11 of Centos6.2 and Ubuntu 11.10 respectively.  Things worked perfecting on 3.0.x and later with 3.4.9 (for Win7 use)

The problem relates to DST files.  These are AutoCAD sheetset files.  These are essentially database files where users should be able to update from different endpoints at the same time.  What is happening is that whomever is the file owner can open the file R/W, all other users within the group can only open it read only - even with RW permissions set.
1.  For diagnostics, I have the permission on the file set to 777.
2.  Folder permissions have been set to 777 
3.  If I change the file owner from user1 to user2, the file will then operate as expected for user2, but it will show as read-only for user1.
4.  I have played with oplock settings in different combinations on these test servers (oplocks, level2 oplocks, kernel opocks) for this file type.

I was hoping to utilize a mixed Samba3/4 domain in the near future, but this may preclude me from moving forward.
Comment 1 Jim Salter 2012-05-18 19:29:07 UTC
This bug bit me too.  DSTs show as locked for absolutely anybody but the file owner, regardless of permissions, oplocks, kernel oplocks, oplock vetoes, you name it.  This is on Samba 3.6.3 from repos on Ubuntu 12.04-LTS Server.

I think the permissions aren't mapping quite right in general on 3.6.3; when I look at file permissions from Windows clients on files chmod 777, I see permissions as "special" for the owner, group, and Everyone with most but not all of the flags checked when you drill down into the advanced properties.  This is on files as well as folders - in the past, permissions didn't look right on folders, but they DID look just as expected on individual files (a 777 would show Full control for owner, group, and everyone when looked at on Windows clients).

Not sure if relevant - I did not have ACLs enabled on my Samba server's underlying filesystem.
Comment 2 Carter 2012-07-11 18:44:23 UTC
I was also having this issue. The way I fixed it was a little counter intuitive, but I am not too knowledgeable as to how samba or file locks actually work. It seems as if changing the permissions to 660 or 666 allows the sheet set file (*.dst) to be controlled by multiple users. Try changing an existing file's permissions then test. If successful, try changing create mask to 0666 or 0660 and force create mode to 0666 or 0660, then create a new sheet set and check for proper functionality. Hope this helps.
Comment 3 Carter 2012-07-11 18:56:37 UTC
For reference I am running Samba version 3.5.10-125.e16