Bug 8804 - rsync -aH --only-write-batch hangs
rsync -aH --only-write-batch hangs
Status: RESOLVED DUPLICATE of bug 8565
Product: rsync
Classification: Unclassified
Component: core
x64 Linux
: P5 normal
: ---
Assigned To: Wayne Davison
Rsync QA Contact
Depends on:
  Show dependency treegraph
Reported: 2012-03-09 09:45 UTC by Christian Heinlein
Modified: 2012-03-13 00:11 UTC (History)
0 users

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Christian Heinlein 2012-03-09 09:45:59 UTC
The following command hangs:
mkdir 1
touch 1/a
ln 1/a 1/b
rsync -aH --only-write-batch=1-2 1/ 2

Adding --no-inc-recursive solves the problem.
Comment 1 Wayne Davison 2012-03-13 00:11:41 UTC
This will be fixed in 3.1.0.

*** This bug has been marked as a duplicate of bug 8565 ***