Bug 8754 - 64 bit clients do not get list of available drivers when using APW to install drivers on Samba server
64 bit clients do not get list of available drivers when using APW to install...
Status: RESOLVED INVALID
Product: Samba 3.6
Classification: Unclassified
Component: Printing
3.6.3
All All
: P5 normal
: ---
Assigned To: printing-maintainers
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-10 00:24 UTC by Chris Smith
Modified: 2012-02-22 14:57 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Smith 2012-02-10 00:24:39 UTC
Classic way to install drivers:
http://www.samba.org/samba/docs/man/Samba-HOWTO-Collection/classicalprinting.html#id2627720
does not work well with 64 bit client (Windows 7 in test case).
After clicking "No" in the error dialog, then selecting the "Advanced" tab , then "New Driver" the user is not presented with the list of available drivers as they are with a 32 bit client.

No clue if this is a Samba bug or a Windows bug, but gotta start somewhere :)

Chris
Comment 1 Chris Smith 2012-02-21 23:29:55 UTC
Anything happening with this bug?

Also want to add that the problem isn't just 3.6.3, happened to me with 3.3.2 recently.
Comment 2 David Disseldorp 2012-02-22 09:14:13 UTC
Configuring point and print driver sharing in 64bit and mixed 32/64 bit Windows client environments requires a differing procedure to the regular (32 bit only) add printer wizard usage:
- The 64bit driver must be uploaded using the
  "//share/printers/ -> server properties" wizard. This wizard allows
  the uploading of printer drivers that differ in architecture to what
  is reported by the spoolss server (configurable in 3.6.3).
- A 32bit driver with an identical name must also be uploaded to the
  server and associated with the printer, the regular add printer wizard
  can be used for this.

For further details see the "Using Point and Print with Different Processor
Architectures" section in:
http://download.microsoft.com/download/5/c/3/5c331f2d-3c1e-40b8-a2ec-0282c047d201/Pointandprint.doc
Comment 3 Chris Smith 2012-02-22 14:57:35 UTC
(In reply to comment #2)
> Configuring point and print driver sharing in 64bit and mixed 32/64 bit Windows
> client environments requires a differing procedure to the regular (32 bit only)
> add printer wizard usage:

Thanks David. I'm going to mark this as resolved.