Bug 8696 - can't remove a symlink targeting at itself
can't remove a symlink targeting at itself
Status: RESOLVED DUPLICATE of bug 8663
Product: Samba 3.6
Classification: Unclassified
Component: File services
3.6.0
All All
: P5 normal
: ---
Assigned To: Volker Lendecke
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-11 16:08 UTC by Frantisek
Modified: 2012-01-11 21:32 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Frantisek 2012-01-11 16:08:00 UTC
Hello,
I have samba Linux server (version 3.6.0). I access it from Linux and MacOSX clients.
I can create a symlink pointing at the symlink itself at a mounted share, but I'm not allowed to remove the symlink after that.

How to reproduce the bug:
  $ cd /path/to/share
  $ ln -s file.link file.link
  ln: failed to create symbolic link 'file.link': Not a directory

But the symlink exists at the share!

  $ rm file.link
  rm: cannot remove 'file.link': Not a directory

Regards,
Frantisek
Comment 1 Jeremy Allison 2012-01-11 21:32:18 UTC

*** This bug has been marked as a duplicate of bug 8663 ***