Bug 8662 - Compile error with Samba4
Compile error with Samba4
Status: RESOLVED INVALID
Product: Samba 4.0
Classification: Unclassified
Component: smbtorture
unspecified
Other Linux
: P5 regression
: ---
Assigned To: Andrew Bartlett
samba4-qa@samba.org
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-14 20:14 UTC by Alex
Modified: 2012-01-04 20:40 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alex 2011-12-14 20:14:45 UTC
Dear all,

I am trying to compile Samba4 alpha17 on Debian Squeeze (armel). Unfortunately the compile always stops at the same point:

[1254/3340] Compiling source4/torture/rpc/samr.c
../source4/torture/rpc/samr.c: In function 'samr_very_rand_pass':
../source4/torture/rpc/samr.c:607: warning: cast increases required alignment of target type
../source4/torture/rpc/samr.c:608: warning: cast increases required alignment of target type
../source4/torture/rpc/samr.c: In function 'test_SetUserPass_21':
../source4/torture/rpc/samr.c:1049: warning: cast increases required alignment of target type
../source4/torture/rpc/samr.c:1056: warning: cast increases required alignment of target type
../source4/torture/rpc/samr.c:1073: warning: cast increases required alignment of target type
../source4/torture/rpc/samr.c:1082: warning: cast increases required alignment of target type
../source4/torture/rpc/samr.c: In function 'test_SetUserPass_level_ex':
../source4/torture/rpc/samr.c:1204: warning: cast increases required alignment of target type
../source4/torture/rpc/samr.c:1211: warning: cast increases required alignment of target type
../source4/torture/rpc/samr.c:1285: warning: cast increases required alignment of target type
../source4/torture/rpc/samr.c:1293: warning: cast increases required alignment of target type
gcc: Internal error: Killed (program cc1)
Please submit a full bug report.
See <file:///usr/share/doc/gcc-4.4/README.Bugs> for instructions.
Waf: Leaving directory `/srv/system/repository/source/openchange/sogo/samba4/bin'
Build failed:  -> task failed (err #1):
        {task: cc samr.c -> samr_8.o}
make[1]: *** [all] Error 1
make[1]: Leaving directory `/srv/system/repository/source/openchange/sogo/samba4'
Error in samba4 make (error code 2)
make: *** [samba] Error 1

Any ideas?
Comment 1 Andrew Bartlett 2011-12-14 20:23:26 UTC
Shouldn't this be filed with GCC?
Comment 2 Matthias Dieter Wallnöfer 2012-01-04 20:40:23 UTC
Does not seem to be our issue, seems to be gcc specific.