Bug 8623 - Crash when trying to browse samba printers
Crash when trying to browse samba printers
Status: RESOLVED FIXED
Product: Samba 3.6
Classification: Unclassified
Component: libsmbclient
3.6.1
All All
: P5 normal
: ---
Assigned To: Karolin Seeger
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-18 14:34 UTC by Andreas Schneider
Modified: 2011-11-19 19:06 UTC (History)
1 user (show)

See Also:


Attachments
v3-6-test patch (851 bytes, patch)
2011-11-18 14:34 UTC, Andreas Schneider
asn: review+
gd: review+
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Schneider 2011-11-18 14:34:29 UTC
Created attachment 7121 [details]
v3-6-test patch

system-config-printer uses libsmbclient and it is crashing while browsing samba printers. The cause of this is wrong reinitialized variable.
Comment 1 Andreas Schneider 2011-11-18 14:49:59 UTC
See https://bugzilla.redhat.com/show_bug.cgi?id=754525
Comment 2 Guenther Deschner 2011-11-18 15:07:32 UTC
This has been addressed by 5db0cd55d4db9cc71f32dc0097e2f014c22967bc. This needs to be cherry-picked to 3.6.
Comment 3 Guenther Deschner 2011-11-18 15:09:10 UTC
Karolin, please pick for 3.6.x
Comment 4 Karolin Seeger 2011-11-19 19:06:53 UTC
Pushed to v3-6-test.
Closing out bug report.

Thanks!