Bug 8612 - New added printers don't appear
New added printers don't appear
Status: RESOLVED DUPLICATE of bug 8554
Product: Samba 3.6
Classification: Unclassified
Component: Printing
x86 Linux
: P5 major
: ---
Assigned To: printing-maintainers
Samba QA Contact
Depends on:
  Show dependency treegraph
Reported: 2011-11-15 17:52 UTC by Marc Muehlfeld
Modified: 2012-07-12 15:05 UTC (History)
2 users (show)

See Also:

Level 10 debug logs (82.67 KB, application/octet-stream)
2011-11-15 17:52 UTC, Marc Muehlfeld
no flags Details
Client log from driver assign problem (4.12 MB, text/plain)
2011-11-16 11:46 UTC, Marc Muehlfeld
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marc Muehlfeld 2011-11-15 17:52:03 UTC
Created attachment 7103 [details]
Level 10 debug logs


in 3.5.12 I created a new section for a new printer in smb.conf:

        path = /var/spool/lpd/samba
        browseable = yes
        writeable = no
        printable = yes
        guest ok = yes
        printer name = HPCP1515-1

and restarted the service. The new printer appeared in "\\servername\Drucker und Faxgeräte". Fine.

I didn't do any configuration on the new added printer in 3.5.12 (not even assign a driver to it). Then I migrated my test environment to 3.6.1. But the printer isn't shown any more.

Also if I add more printer sections like the one above, they don't appear.

Then I did the ultimate check (in my test environment of course): I deleted everything in my lock directory (incl. subdirectories) and restarted the services. Now now of the 26 printers I had before are shown any more in "\\servername\Drucker und Faxgeräte"

The debug level 10 log shows a lot of registry errors like
[2011/11/15 17:33:48.639794,  2] rpc_client/cli_winreg_spoolss.c:1644(winreg_get_printer)
  winreg_get_printer: Could not open key SOFTWARE\Microsoft\Windows NT\CurrentVersion\Print\Printers\SHMX2600-1_SW: WERR_BADFILE

I also tried 3.6.0 which also had this bug.

I attached a level 10 debug log from the server (contains opening "\\servername\Drucker und Faxgeräte")
Comment 1 Björn Baumbach 2011-11-16 09:01:44 UTC

*** This bug has been marked as a duplicate of bug 8554 ***
Comment 2 Björn Baumbach 2011-11-16 09:53:46 UTC
could you try the following, please?
rpcclient -c "enumprinters" <hostname/ip> -U <username> ...

Don't forget to add the host and username to the rpcclient command.

Comment 3 Marc Muehlfeld 2011-11-16 10:10:56 UTC
This workaround command makes the new added printers appear (I just forgot the hostname).
Comment 4 Marc Muehlfeld 2011-11-16 11:46:56 UTC
Created attachment 7107 [details]
Client log from driver assign problem

With the workaround the printers appear, as i already said. Now I tried to assign a driver to the printer. But there the Client (here XP Prof SP3) always freezes.

I right-click to a printer -> properties -> extended tab -> choose one of the drivers that are already on the server -> click to "OK".

The "OK" button stays pressed and this screen freezes now for hours. The only way is to kill explorer.exe.

I tried meanwhile 4 different drivers (from different vendors). Happend with all.

I created a level 10 debug from the assign process. I already saw in the log messages with odd pathes like
[2011/11/16 12:42:45.704378, 10] smbd/filename.c:1313(filename_convert)
  filename_convert: unix_convert failed for name W32X86/3/print$/W32X86/3/SN0HGD.DLL with NT_STATUS_OBJECT_PATH_NOT_FOUND

I don't know if this is a new bug or if it's associated with this one.
Comment 5 Björn Baumbach 2012-05-10 14:37:29 UTC
Dear Marc,


this problem is not related to this bug.
I fixed this problem last year. Please see 8618.

Best regards
Comment 6 Björn Baumbach 2012-05-10 14:40:12 UTC
Fixed by fixing bug 8554
Comment 7 Björn Jacke 2012-07-12 15:05:34 UTC

*** This bug has been marked as a duplicate of bug 8554 ***