Bug 858 - profiles binary core dumps in Solaris 9
profiles binary core dumps in Solaris 9
Status: CLOSED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: User/Group Accounts
3.0.11
All Solaris
: P3 normal
: none
Assigned To: Tim Potter
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-05 08:28 UTC by Jeff Gardiner
Modified: 2005-08-24 10:24 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jeff Gardiner 2003-12-05 08:28:37 UTC
The samba/bin/profiles binary in Solaris 9 causes Segmentation fault.  I've 
checked all of the other binaries, and the remainder seem to work fine. 
 
I compiled all binaries from source using ./configure --with-ldap=no and 
everything seems to compile fine.  I've been running smbd and nmbd and 
winbindd - Version 3.0.1pre3 
 
I've kept the core file if any are interested. 
 
I don't know what other info to provide, but if I've missed anything I can 
recreate the behavior and am willing to provide further info if needed.
Comment 1 Tim Potter 2003-12-05 17:57:07 UTC
A stack backtrace would be great.  If you run 'gdb profiles core', type 'bt
full' and post the results in bugzilla we can get going on fixing it.
Comment 2 Jeff Gardiner 2003-12-08 07:52:26 UTC
# gdb profiles core 
GNU gdb 4.17 
Copyright 1998 Free Software Foundation, Inc. 
GDB is free software, covered by the GNU General Public License, and you are 
welcome to change it and/or distribute copies of it under certain conditions. 
Type "show copying" to see the conditions. 
There is absolutely no warranty for GDB.  Type "show warranty" for details. 
This GDB was configured as "sparc-sun-solaris2.5.1"...(no debugging symbols 
found)... 
Core was generated by `./profiles'. 
Program terminated with signal 11, Segmentation Fault. 
Reading symbols from /usr/lib/libsendfile.so.1...(no debugging symbols 
found)...done. 
Reading symbols from /usr/lib/libsec.so.1...(no debugging symbols 
found)...done. 
Reading symbols from /usr/lib/libgen.so.1...(no debugging symbols 
found)...done. 
Reading symbols from /usr/lib/libresolv.so.2...(no debugging symbols 
found)...done. 
Reading symbols from /usr/lib/libsocket.so.1...(no debugging symbols 
found)...done. 
Reading symbols from /usr/lib/libnsl.so.1...(no debugging symbols 
found)...done. 
Reading symbols from /usr/lib/libdl.so.1...(no debugging symbols 
found)...done. 
Reading symbols from /usr/lib/libc.so.1...(no debugging symbols found)...done. 
Reading symbols from /usr/lib/libmp.so.2...(no debugging symbols 
found)...done. 
Reading symbols from /usr/platform/SUNW,Ultra-250/lib/libc_psr.so.1...(no 
debugging symbols found)... 
done. 
#0  0xff133474 in strlen () 
(gdb) bt 
#0  0xff133474 in strlen () 
#1  0xff185798 in _doprnt () 
#2  0xff187168 in fprintf () 
#3  0x11630 in main () 
(gdb)  bt full 
No symbol table is loaded.  Use the "file" command. 
 
 
Let me know what else I can do to assist.  This didn't seem to helpful, and I 
don't have much experience debugging (Sorry).  Let me know what other 
information I can provide or what other commands to execute. 
 
 
Comment 3 Gerald (Jerry) Carter 2004-10-31 14:29:42 UTC
unless someone picks ups active maintanence of the profiles 
tool, i'm marking this a won't fix since it has been open for 
10 months and is trivial to reproduce.
Comment 4 Jeff Gardiner 2004-11-01 08:36:53 UTC
I'm now running 3.0.7, and the bug persists (Still dumps).  The gdb core looks 
as follows: 
 
GNU gdb 4.17 
Copyright 1998 Free Software Foundation, Inc. 
GDB is free software, covered by the GNU General Public License, and you are 
welcome to change it and/or distribute copies of it under certain conditions. 
Type "show copying" to see the conditions. 
There is absolutely no warranty for GDB.  Type "show warranty" for details. 
This GDB was configured as "sparc-sun-solaris2.5.1"...(no debugging symbols 
found)... 
Core was generated by `./profiles'. 
Program terminated with signal 11, Segmentation Fault. 
Reading symbols from /usr/lib/libsendfile.so.1...(no debugging symbols 
found)...done. 
Reading symbols from /usr/lib/libsec.so.1...(no debugging symbols 
found)...done. 
Reading symbols from /usr/lib/libgen.so.1...(no debugging symbols 
found)...done. 
Reading symbols from /usr/lib/libresolv.so.2...(no debugging symbols 
found)...done. 
Reading symbols from /usr/lib/libsocket.so.1...(no debugging symbols 
found)...done. 
Reading symbols from /usr/lib/libnsl.so.1...(no debugging symbols 
found)...done. 
Reading symbols from /usr/lib/libdl.so.1...(no debugging symbols 
found)...done. 
Reading symbols from /opt/csw/lib/libiconv.so.2...(no debugging symbols 
found)...done. 
Reading symbols from /usr/lib/libc.so.1...(no debugging symbols found)...done. 
Reading symbols from /usr/lib/libmp.so.2...(no debugging symbols 
found)...done. 
Reading symbols from /usr/platform/SUNW,Ultra-250/lib/libc_psr.so.1...(no 
debugging symbols found)...done. 
#0  0xfefb44e8 in strlen () 
(gdb) quit 
 
 
I'm assuming, that WONTFIX means there should be no further comments here. 
 
Cheers 
Jeff 
Comment 5 Gerald (Jerry) Carter 2005-02-07 09:05:00 UTC
originally reported against one of the 3.0.0rc[1-4] releases.
Cleaning up non-production versions.
Comment 6 Gerald (Jerry) Carter 2005-02-07 15:17:27 UTC
reopened so I mark mark as fixed.
Comment 7 Gerald (Jerry) Carter 2005-02-07 15:18:53 UTC
fixed for 3.0.12.
Comment 8 Gerald (Jerry) Carter 2005-08-24 10:24:22 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.