Bug 857 - only 13 share foldes characters can 't been seen from windows 98, from windows 2000 can be seen all
Summary: only 13 share foldes characters can 't been seen from windows 98, from window...
Status: RESOLVED INVALID
Alias: None
Product: Samba 3.0
Classification: Unclassified
Component: File Services (show other bugs)
Version: 3.0.0
Hardware: All Solaris
: P3 major
Target Milestone: none
Assignee: Gerald (Jerry) Carter
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-12-05 07:18 UTC by Andres Yacopino
Modified: 2005-11-14 09:28 UTC (History)
1 user (show)

See Also:


Attachments
The problem folder with 13 characters long (95.85 KB, image/jpeg)
2003-12-05 09:23 UTC, Andres Yacopino
no flags Details
Subfolders with no problems!!! (126.91 KB, image/jpeg)
2003-12-05 09:24 UTC, Andres Yacopino
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andres Yacopino 2003-12-05 07:18:02 UTC
I have installed samba 3.0.0(before I have 2.2.7), and i can ´t see shares with
names that are long to 13 characters (i can see only 13 characters).
This problem is when i browsing with a pc with windows 98 not when i am using
windows 2000.
The share are in a Sun Server (sparc) with Solaris 8.
I have compiled the samba 3.0.0 with -acl support.
Thank you very much
Andres Yacopino
Comment 1 Gerald (Jerry) Carter 2003-12-05 07:38:02 UTC
And your saying that win98 could view lo9ng share names 
with Samba 2.2.7 ?  I'm not sure I believe that.  Can you 
send me a screen shot of it working against 2.2.7.
Comment 2 Andres Yacopino 2003-12-05 09:22:51 UTC
I have noticed the problem only recently, and i have upgraded the 2.2.7 version
to 3. I can ´t test 2.2.7. . May be what you said, that even worked for 2.2.7.
I am sending you two images.
In the first the problem, for example the folder comisiones_bs is
comisiones_bsas actually.
(acadb_archivo=acadb_archivos
cobranzas_bsa=cobranzas_bsas
comisiones_ro=comisiones_ros
etc..)

In the second image, you can see that the problem is only in the root of the
sharefolders.
Comment 3 Andres Yacopino 2003-12-05 09:23:32 UTC
Created attachment 303 [details]
The problem folder with 13 characters long
Comment 4 Andres Yacopino 2003-12-05 09:24:37 UTC
Created attachment 304 [details]
Subfolders with no problems!!!
Comment 5 Gerald (Jerry) Carter 2004-03-04 08:03:59 UTC
Windows 98 cannot view long share names.  It is a feature of 
the client OS.
Comment 6 Gerald (Jerry) Carter 2005-11-14 09:28:53 UTC
database cleanup