Bug 8540 - /usr/local/samba/lib not searched on Solaris 8
/usr/local/samba/lib not searched on Solaris 8
Status: RESOLVED DUPLICATE of bug 8000
Product: Samba 3.6
Classification: Unclassified
Component: Build environment
3.6.0
Sparc Solaris
: P5 minor
: ---
Assigned To: Björn Jacke
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-21 16:50 UTC by Michael Pelletier
Modified: 2011-10-21 17:38 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Pelletier 2011-10-21 16:50:46 UTC
I generated executables once I got through 8531, 32, and 34, but the executables that were generated did not have the /usr/local/samba/lib path, and so could not find libtalloc and libtdb:


$ ldd /usr/local/samba/sbin/smbd
 libthread.so.1 =>        /usr/lib/libthread.so.1
        libpam.so.1 =>   /usr/lib/libpam.so.1
        libsec.so.1 =>   /usr/lib/libsec.so.1
        libsendfile.so.1 =>      /usr/lib/libsendfile.so.1
        libresolv.so.2 =>        /usr/lib/libresolv.so.2
        librt.so.1 =>    /usr/lib/librt.so.1
        libnsl.so.1 =>   /usr/lib/libnsl.so.1
        libsocket.so.1 =>        /usr/lib/libsocket.so.1
        libaio.so.1 =>   /usr/lib/libaio.so.1
        libdl.so.1 =>    /usr/lib/libdl.so.1
        libtalloc.so.2 =>        (file not found)
        libtdb.so.1 =>   (file not found)
        libwbclient.so.0 =>      (file not found)
        libz.so =>       /usr/lib/libz.so
        libc.so.1 =>     /usr/lib/libc.so.1
        libgcc_s.so.1 =>         (file not found)
        libcmd.so.1 =>   /usr/lib/libcmd.so.1
        libmp.so.2 =>    /usr/lib/libmp.so.2
        /usr/platform/SUNW,Sun-Fire-V210/lib/libc_psr.so.1
$ ls -l /usr/local/samba/lib/libtalloc.so.2
lrwxrwxrwx   1 root     other         18 Oct 21 11:51 /usr/local/samba/lib/libtalloc.so.2 -> libtalloc.so.2.0.5

Was /usr/local/samba/lib supposed to be incorporated into the library search path of the executable and something tripped up on Solaris 8? I can't quite tell yet. The config.log is in bug #8532.

I'm weighing -R option and the use of LD_RUN_PATH.
Comment 1 Michael Pelletier 2011-10-21 17:21:38 UTC
Adding "-R$(LIBDIR)" to SHLD_DSO addressed everything except libgcc_s.so.1, and adding "-R/usr/local/lib" addressed that. I'm not sure if there's potential side-effects, though.
Comment 2 Björn Jacke 2011-10-21 17:38:05 UTC
The library path topic has been discusses often before. and rpath is an evil thing (imho)

*** This bug has been marked as a duplicate of bug 8000 ***