Bug 8537 - compile error @ tls.c when using gcc Version 4.6.1
compile error @ tls.c when using gcc Version 4.6.1
Status: RESOLVED FIXED
Product: Samba 4.0
Classification: Unclassified
Component: Build
unspecified
x64 Linux
: P5 normal
: ---
Assigned To: Andrew Bartlett
samba4-qa@samba.org
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-20 10:04 UTC by Klaus Beckstette
Modified: 2011-11-30 08:36 UTC (History)
1 user (show)

See Also:


Attachments
Screenshot of error message (51.75 KB, application/pdf)
2011-10-20 10:04 UTC, Klaus Beckstette
no flags Details
make output / cc version / gnutls version (1.00 KB, text/plain)
2011-11-21 09:29 UTC, Klaus Beckstette
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Klaus Beckstette 2011-10-20 10:04:42 UTC
Created attachment 7012 [details]
Screenshot of error message

When using gcc V 4.6.1 20111012 (under openSUSE 12.1 factory) a reproducible compile error breaks the make process (see attachment)

Using gcc 4.5.1 20101208 (under openSUSE 11.4) brings no error.
Comment 1 Matthias Dieter Wallnöfer 2011-11-19 21:00:26 UTC
Is this still broken? Is the GNUTLS library package up-to-date?
Comment 2 Klaus Beckstette 2011-11-21 09:29:09 UTC
Created attachment 7129 [details]
make output / cc version / gnutls version
Comment 3 Klaus Beckstette 2011-11-21 09:30:41 UTC
(In reply to comment #1)
> Is this still broken? Is the GNUTLS library package up-to-date?

Yes: Still broken :-(
Just tested with fresh installed openSUSE 12.1 systems (x86 and x64).
Details see attachment 7129 [details]

Klaus
Comment 4 Klaus Beckstette 2011-11-21 09:54:21 UTC
(In reply to comment #3)
> (In reply to comment #1)
> > Is this still broken? Is the GNUTLS library package up-to-date?
> 
> Yes: Still broken :-(
> Just tested with fresh installed openSUSE 12.1 systems (x86 and x64).
> Details see attachment 7129 [details]
> 
> Klaus

Sorry, forgot: make run is o.k. under UBUNTU 11.10 with cc Version 4.6.1!

May it be that openSUSE sets diffenet default action. See:
"cc1: some warnings being treated as errors"
Comment 5 Matthias Dieter Wallnöfer 2011-11-28 17:45:03 UTC
The problem is due to GNUTLS 3.0 which removed "gnutls_transport_set_lowat": http://old.nabble.com/gnutls_transport_set_lowat-deprecated-td32554230.html
Comment 7 Andrew Bartlett 2011-11-28 21:19:01 UTC
If we do not use it, why not just remove it?
Comment 8 Matthias Dieter Wallnöfer 2011-11-29 07:42:48 UTC
On older GNUTLS releases (<3) the "lowat" feature is active by default - hence it has to be deactivated explicitly. On GNUTLS >= 3 the feature has been removed and therefore no call needed - my patch should exactly do this.

(In reply to comment #7)
> If we do not use it, why not just remove it?
Comment 9 Matthias Dieter Wallnöfer 2011-11-30 08:36:02 UTC
After another review done by metze the fix has been submitted by me to autobuild. It should appear in "master" as soon as possible. Hence marking this bug as "FIXED"