Bug 853 - smb_panic & repeated crashes
smb_panic & repeated crashes
Status: RESOLVED DUPLICATE of bug 687
Product: Samba 3.0
Classification: Unclassified
Component: File Services
3.0.0
All Linux
: P3 critical
: none
Assigned To: Samba Bugzilla Account
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-04 03:34 UTC by rob
Modified: 2005-11-14 09:24 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description rob 2003-12-04 03:34:03 UTC
Samba 3.0.0 compiled from source
gcc 2.95.3
libc-2.2.4
kernel 2.4.20
filesystem: reiserfs
samba verion 3.0.0 running against openldap-2.1.22
clients: win2kSP2-4, WinXPSP1a

unix charset = ISO8859-1

I have a second samba 3.0.0 server where I used "convmv" to convert the
filenames to utf8. This server does not crash, but is also not used as much. The
server in question has over 2 million files on it so I hesitate to run "convmv" 


This is what my logs show sometimes every couple of minutes sometimes only once
a couple of hours.

[2003/12/02 11:17:48, 0] lib/fault.c:fault_report(36)
  ===============================================================
[2003/12/02 11:17:48, 0] lib/fault.c:fault_report(37)
  INTERNAL ERROR: Signal 11 in pid 5870 (3.0.0)
  Please read the appendix Bugs of the Samba HOWTO collection
[2003/12/02 11:17:48, 0] lib/fault.c:fault_report(39)
  ===============================================================
[2003/12/02 11:17:48, 0] lib/util.c:smb_panic(1400)
  PANIC: internal error
[2003/12/02 11:17:48, 0] lib/util.c:smb_panic(1407)
  BACKTRACE: 16 stack frames:
   #0 /usr/local/samba/sbin/smbd(smb_panic+0x16c) [0x8189c8c]
   #1 /usr/local/samba/sbin/smbd(dbgtext+0x194) [0x8179634]
   #2 /usr/local/samba/sbin/smbd(dbgtext+0x1f2) [0x8179692]
   #3 /lib/libc.so.6(__libc_sigaction+0x138) [0x401ac7f8]
   #4 /usr/local/samba/sbin/smbd(alloc_sub_basic+0x23) [0x818f343]
   #5 /usr/local/samba/sbin/smbd(lp_talloc_free+0x67) [0x80743f7]
   #6 /usr/local/samba/sbin/smbd(lp_servicename+0x37) [0x8075967]
   #7 /usr/local/samba/sbin/smbd(make_connection+0x2c0) [0x80bb270]
   #8 /usr/local/samba/sbin/smbd(reply_tcon_and_X+0x228) [0x8093eb8]
   #9 /usr/local/samba/sbin/smbd(respond_to_all_remaining_local_messages+0x65b)
[0x80b85db]
   #10 /usr/local/samba/sbin/smbd(respond_to_all_remaining_local_messages+0x700)
[0x80b8680]
   #11 /usr/local/samba/sbin/smbd(process_smb+0x18e) [0x80b893e]
   #12 /usr/local/samba/sbin/smbd(smbd_process+0x150) [0x80b92c0]
   #13 /usr/local/samba/sbin/smbd(main+0x69f) [0x81dcbef]
   #14 /lib/libc.so.6(__libc_start_main+0xbe) [0x4019b7ee]
   #15 /usr/local/samba/sbin/smbd(_start+0x21) [0x8073861]

Regards

rob
Comment 1 Gerald (Jerry) Carter 2003-12-07 22:49:51 UTC

*** This bug has been marked as a duplicate of 687 ***
Comment 2 Gerald (Jerry) Carter 2005-11-14 09:24:46 UTC
database cleanup