Bug 8519 - samba-tool user setexpiry command inconsistency
samba-tool user setexpiry command inconsistency
Status: RESOLVED INVALID
Product: Samba 4.0
Classification: Unclassified
Component: Tools
unspecified
All All
: P5 normal
: ---
Assigned To: Andrew Bartlett
samba4-qa@samba.org
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-10 22:56 UTC by Theresa Halloran
Modified: 2011-11-21 15:32 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Theresa Halloran 2011-10-10 22:56:50 UTC
samba-tool user setexpiry user1 --days=10 sets the user1 account expiration to current day + 10
samba-tool user setexpiry user1 --noexpiry sets the user1 account expiration to never and the password also to never expire.
This is incorrect.  The password expiration function should be moved to the samba-tool user setpassword command.
Comment 1 Matthias Dieter Wallnöfer 2011-10-11 06:32:50 UTC
Ekacnet, do you have an idea here?
Comment 2 Matthias Dieter Wallnöfer 2011-11-19 20:55:51 UTC
Theresa,

has this been fixed in the meantime or do we still need to keep this open?
Comment 3 Theresa Halloran 2011-11-21 12:51:06 UTC
Hello Matthias,

I was just looking at this last week and it seems that the "bug" i reported is an intentional "feature".  I suppose you can close it out as a user error.  My initial reaction was that the command external is poor (samba-tool user setexpiry being used to set expiration of the account and the password), I believe after looking at the code, it is working as intended.

Theresa
Comment 4 Matthias Dieter Wallnöfer 2011-11-21 15:32:24 UTC
The described behaviour is the expected one as Theresa states - hence closing with "INVALID".