Bug 8506 - Only advertise shares to permitted hosts
Only advertise shares to permitted hosts
Status: RESOLVED DUPLICATE of bug 1597
Product: rsync
Classification: Unclassified
Component: core
All FreeBSD
: P5 enhancement
: ---
Assigned To: Wayne Davison
Rsync QA Contact
Depends on:
  Show dependency treegraph
Reported: 2011-10-03 23:00 UTC by Garrett Cooper
Modified: 2011-10-04 05:57 UTC (History)
0 users

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Garrett Cooper 2011-10-03 23:00:01 UTC
Currently, if I do something the the following:

rsync host::

It will list all of the shares made available by rsyncd. As noted by a FreeNAS user, it would be nice if the shares weren't advertised to users that didn't have access to them.

This can be broken down to the following scenarios:

1. No access to all shares.
2. Mixed access (some available, some not).
3. Access to all shares.

I'll whip up a patch if I have time.

OS is FreeBSD 8.2-RELEASE with rsync 3.0.8 from ports.
Comment 1 Matt McCutchen 2011-10-04 05:57:24 UTC

*** This bug has been marked as a duplicate of bug 1597 ***