Bug 8483 - rsync: chown failed: Permission denied (13)
rsync: chown failed: Permission denied (13)
Status: RESOLVED WORKSFORME
Product: rsync
Classification: Unclassified
Component: core
3.0.8
x86 Solaris
: P5 major
: ---
Assigned To: Wayne Davison
Rsync QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-26 18:25 UTC by Eric C.
Modified: 2013-06-02 22:13 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eric C. 2011-09-26 18:25:53 UTC
Were running into an issue where rsync provides the following error:


rsync: chown "/east/volcombo_a1/fpga-gt/tools/fpgaLampServer/backups/lamp/2011.09.17.00.30.05/mysql/idte/.Downloads.MYD.BQayuj" failed: Permission denied (13)
rsync: chown "/east/volcombo_a1/fpga-gt/tools/fpgaLampServer/backups/lamp/2011.09.17.00.30.05/mysql/idte/.Downloads.MYI.CQayuj" failed: Permission denied (13)
rsync: chown "/east/volcombo_a1/fpga-gt/tools/fpgaLampServer/backups/lamp/2011.09.17.00.30.05/mysql/idte/.FPGACheckOut.MYD.DQayuj" failed: Permission denied (13)
rsync: chownfailed: Permission denied (13)


Were using the following cmds at present

/usr/local/bin/rsync -vaHEu --delete-excluded --progress --stats /atlantic/fpga-gt/tools/ /east/volcombo_a1/fpga-gt/tools/ >> /east/migrationlogs/rsynclogs/fpga-gt-tools.log"
Comment 1 Kevin Korb 2011-09-26 18:28:43 UTC
In order to chown a file you must be running as root and the target filesystem must support file ownerships.
Comment 2 Eric C. 2011-09-26 18:32:11 UTC
The destination is a Netapp filer and the source is a SUN7410. Some of the other directories work okay. It seems to be the larger file systems it has issue with.
Comment 3 Eric C. 2011-09-26 18:33:51 UTC
These are run under roots cron job.

Thanks

Eric
Comment 4 Eric C. 2011-09-26 18:40:09 UTC
The results of the rsync leave this as a structure


drwxr-xr-x+ 68 root     ccusers     8192 Aug 31 14:30 .
drwxr-x---+  2 root     sys         4096 Dec 11  2010 .$EXTEND
drwxr-xr-x+ 18 root     root        4096 Sep 24 12:33 ..
drwxrwxrwx+ 10 root     root        4096 Sep 26 12:00 .snapshot
drwxr-xr-x+  9 Xaltera  fpgauser    4096 Oct  3  2006 al
drwxr-xr-x+ 26 andersb  ccusers     4096 Sep 25 18:07 and
drwx------+  3 pcuser   nogroup     4096 Sep 21  2006 backu
drwxr-xr-x+ 14 beckere  ccusers     4096 Jun 23  2006 be
drwxr-xr-x+  3 prjmgr   dcumentn    4096 May 20  2003 bel
drwxr-xr-x+ 47 bol46430 ccusers     8192 Sep 16 15:45 b
drwxr-xr-x+ 13 boledoc  ccusers     4096 Aug 20  2003 bo
drwx------+ 68 pcuser   nogroup    12288 Aug 26 17:06 ce
drwxr-xr-x+ 61 cha49316 ccusers     8192 Sep 26 11:37 ch
drwxr-xr-x+ 17 chenh    ccusers     8192 Aug 31  2010 c
drwxr-xr-x+ 25 cho51231 ccusers     8192 Jul 10  2008 cho
drwxr-xr-x+ 74 chodowp  ccusers    20480 Sep 23 10:32 ch
drwxr-xr-x+ 83 crockej  ccusers    16384 Sep 23 12:12 cr
drwxr-xr-x+ 29 curryj   ccusers     4096 Sep 23 11:40 cu
drwxr-xr-x+  2 den50565 fpgauser    4096 Jul  2  2010 de
drwxr-xr-x+ 38 devlind  ccusers     8192 Sep 21 10:24 dev
drwxr-xr-x+121 dikmeno  ccusers    16384 Sep 22 15:03 di
drwx------+  2 pcuser   nogroup     4096 Sep 12 15:31 fe
drwx------+  2 pcuser   nogroup     4096 Sep 12 15:31 fi
drwx------+  2 pcuser   nogroup     4096 Sep 12 15:31 
drwx------+  2 pcuser   nogroup     4096 Sep 12 15:31 gaj
drwx------+  2 pcuser   nogroup     4096 Sep 12 15:31 gh
drwx------+  2 pcuser   nogroup     4096 Sep 12 15:31 gi
drwx------+  2 pcuser   nogroup     4096 Sep 12 15:31 go
drwx------+  2 pcuser   nogroup     4096 Sep 12 15:31 ha
drwx------+  2 pcuser   nogroup     4096 Sep 12 15:31 ha
drwx------+  2 pcuser   nogroup     4096 Sep 12 15:31 ha
drwx------+  2 pcuser   nogroup     4096 Sep 12 15:31 hey
drwx------+  2 pcuser   nogroup     4096 Sep 12 15:31 h
drwx------+  2 pcuser   nogroup     4096 Sep 12 15:31 jen
drwx------+  2 pcuser   nogroup     4096 Sep 12 15:31 ji
drwx------+  2 pcuser   nogroup     4096 Sep 12 15:31 ji
drwx------+  2 pcuser   nogroup     4096 Sep 12 15:31 jo
drwx------+  2 pcuser   nogroup     4096 Sep 12 15:31 ks
drwx------+  2 pcuser   nogroup     4096 Sep 12 15:31 k
drwx------+  2 pcuser   nogroup     4096 Sep 12 15:31 ku
drwx------+  2 pcuser   nogroup     4096 Sep 12 15:31 k
drwx------+  2 pcuser   nogroup     4096 Sep 12 15:31 lat
drwx------+  2 pcuser   nogroup     4096 Sep 12 15:31 ma
drwx------+  2 pcuser   nogroup     4096 Sep 12 15:31 mar
drwx------+  2 pcuser   nogroup     4096 Sep 12 15:31 mayf
drwx------+  2 pcuser   nogroup     4096 Sep 12 15:31 mic
drwx------+  2 pcuser   nogroup     4096 Sep 12 15:31 mit
drwx------+  2 pcuser   nogroup     4096 Sep 12 15:31 mu
drwx------+  2 pcuser   nogroup     4096 Sep 12 15:31 na
drwx------+  2 pcuser   nogroup     4096 Sep 12 15:31 ne
drwx------+  2 pcuser   nogroup     4096 Sep 12 15:31 pa
drwx------+  2 pcuser   nogroup     4096 Sep 12 15:31 ph
drwx------+  2 pcuser   nogroup     4096 Sep 12 15:31 phy
drwx------+  2 pcuser   nogroup     4096 Sep 12 15:31 pr
drwx------+  2 pcuser   nogroup     4096 Sep 12 15:31 ra
drwx------+  2 pcuser   nogroup     4096 Sep 12 15:31 roy
drwx------+  2 pcuser   nogroup     4096 Sep 12 15:31 sau
drwx------+  2 pcuser   nogroup     4096 Sep 12 15:31 shu
drwx------+  2 pcuser   nogroup     4096 Sep 12 15:31 sta
drwx------+  2 pcuser   nogroup     4096 Sep 12 15:31 svn
drwx------+  2 pcuser   nogroup     4096 Sep 12 15:31 sy
drwx------+  2 pcuser   nogroup     4096 Sep 12 15:31 to
drwx------+  2 pcuser   nogroup     4096 Sep 12 15:31 wa
drwx------+  2 pcuser   nogroup     4096 Sep 12 15:31 we
drwx------+  2 pcuser   nogroup     4096 Sep 12 15:31 
drwx------+  2 pcuser   nogroup     4096 Sep 12 15:31 
drwx------+  2 pcuser   nogroup     4096 Sep 12 15:31 
drwx------+  2 pcuser   nogroup     4096 Sep 12 15:31
Comment 5 Kevin Korb 2011-09-26 18:41:14 UTC
The next step would be to create a file in the same target and attempt to chown it to a different user.  If you can't do that at the command line then the problem is not within rsync.
Comment 6 Eric C. 2011-09-26 21:07:43 UTC
I was able to change permissions manually fine.




# chmod 755 test
# ls -al
total 24
drwx------+  2 pcuser   nogroup     4096 Sep 26 17:01 .
drwxr-xr-x+ 68 root     ccusers     8192 Aug 31 14:30 ..
-rwxr-xr-x   1 root     daemon         0 Sep 26 17:01 test
# chmod 777 test
# ls -al
total 24
drwx------+  2 pcuser   nogroup     4096 Sep 26 17:01 .
drwxr-xr-x+ 68 root     ccusers     8192 Aug 31 14:30 ..
-rwxrwxrwx+  1 root     daemon         0 Sep 26 17:01 test
#
Comment 7 Eric C. 2011-09-26 21:10:48 UTC
# chown root test
# ls -al
total 24
drwx------+  2 pcuser   nogroup     4096 Sep 26 17:01 .
drwxr-xr-x+ 68 root     ccusers     8192 Aug 31 14:30 ..
-rwxrwxrwx+  1 root     daemon         0 Sep 26 17:01 test
# chown pcuser test
# ls -al
total 24
drwx------+  2 pcuser   nogroup     4096 Sep 26 17:01 .
drwxr-xr-x+ 68 root     ccusers     8192 Aug 31 14:30 ..
-rwxrwxrwx+  1 pcuser   daemon         0 Sep 26 17:01 test
#
Comment 8 Wayne Davison 2013-06-02 22:13:49 UTC
If rsync is unable to chown a file, you need to figure out what OS reason/permission you have failed to give it to do its job.  e.g. you have have a file system mounted with root-squash permissions.