Bug 8385 - smbclient can't access a NT4 share since 3.6.0
smbclient can't access a NT4 share since 3.6.0
Status: RESOLVED FIXED
Product: Samba 3.6
Classification: Unclassified
Component: Client Tools
3.6.0
x64 Linux
: P5 normal
: ---
Assigned To: Karolin Seeger
Samba QA Contact
:
Depends on:
Blocks: 8399
  Show dependency treegraph
 
Reported: 2011-08-19 06:41 UTC by Marc Muehlfeld
Modified: 2011-09-01 21:37 UTC (History)
0 users

See Also:


Attachments
strace smbclient 3.6.0 (26.61 KB, text/plain)
2011-08-19 06:41 UTC, Marc Muehlfeld
no flags Details
strace smbclient 3.5.11 (32.17 KB, text/plain)
2011-08-19 06:41 UTC, Marc Muehlfeld
no flags Details
Patch against current upstream (2.03 KB, patch)
2011-08-22 12:27 UTC, Volker Lendecke
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marc Muehlfeld 2011-08-19 06:41:09 UTC
Created attachment 6788 [details]
strace smbclient 3.6.0

I upgraded to 3.6.0, but since that time, I can't connect to a share on a NT4 Wks host any more:

# /usr/bin/smbclient //molek-04/lightcycler -U administrator
protocol negotiation failed: NT_STATUS_IO_TIMEOUT

I thought it could be something with 'client ntlmv2 auth", what is 'yes' since that version. But even if I switch it to 'no' it's the same.

[root@nucleus ~]# smbclient --version
Version 3.6.0 

I have this problem reproducable on all our 3.6.0 machines. From none I can use smbclient to connect to NT4 shares anymore. With 3.5.x versions it's no problem.

Volker Lendecke already told me on the mailing list, that thought that he had this problem already in a 3.6pre version and it was fixed. But I'm running the 3.6.0 final here and having this problem.

Using "-p 139" as parameter is a workaround for the problem.

Volker already told me via mail that the output of poll(2) from the straces of 3.6.0 and 3.5.11 look different.
Comment 1 Marc Muehlfeld 2011-08-19 06:41:27 UTC
Created attachment 6789 [details]
strace smbclient 3.5.11
Comment 2 Volker Lendecke 2011-08-19 06:42:41 UTC
Just to say this is pretty high on my list, but I am right now very busy with
customer issues.
Comment 3 Volker Lendecke 2011-08-22 12:27:46 UTC
Created attachment 6798 [details]
Patch against current upstream

Can you try the attached patch?
Comment 4 Jeremy Allison 2011-08-24 23:51:08 UTC
Pushed to master - this is obvious goodness.

Jeremy.
Comment 5 Jeremy Allison 2011-08-24 23:53:23 UTC
Re-assigning to Karolin for inclusion in 3.6.1.
Jeremy.
Comment 6 Marc Muehlfeld 2011-08-29 05:43:01 UTC
I can confirm that the patch is working. Thanks.
Comment 7 Karolin Seeger 2011-08-30 18:58:22 UTC
Pushed to v3-6-test.
Closing out bug report.

Thanks!